Jump to content
  • 0
Sarah_T

PAinfully slow (20min+) load times in MP

Question

After selecting a profile, the game takes over 20 mintues to load, irrespective of the mods installed, the server selected, or the profile selected.  In single player mode, the game takes seconds to load at this same point.  

 

Another potential symptom is, if I alt tab during this loading cycle, the game goes from "not responding" (and using a lot of CPU) to "Suspended" (And using 0 cpu).  At this point the only option left is an end task via task manager.

 

Win 10 64 bit system.  Steam is active at the time I hit "launch <gamename (ATS or ETS2)>" on the truckers MP window.    This happens EVERY time, so its not a cache load issue.

 

Both games are installed in steam libraries on SSDDs with nothing else on it.

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Dear @Sarah_T,

 

I would suggest to make a complete reinstallation of the game with the help of this article: https://truckersmp.com/kb/147

Since the game as you wrote here working perfectly without the Multiplayer mod, I think this could help.

Also you can try to start TruckersMP with administrator permissions, but before doing that, try to remove all exitsing mod you have installed.

 

Kind Regards,

LogRol

 

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, LogRol said:

Dear @Sarah_T,

 

I would suggest to make a complete reinstallation of the game with the help of this article: https://truckersmp.com/kb/147

Since the game as you wrote here working perfectly without the Multiplayer mod, I think this could help.

Also you can try to start TruckersMP with administrator permissions, but before doing that, try to remove all exitsing mod you have installed.

 

Kind Regards,

LogRol

 

TRuckers MP has been re-downloaded and reinstalled cleanly, and already does run with administrator.

Edited by SarahMaddy
Made it easier to read to avoid confusion.

Share this post


Link to post
Share on other sites
  • 0

I would suggest a somewhat different approach, especially if none of the suggestions above solves the problem.

 

Depending on how comfortable you are with diving in and using some system tools:
Trying to see what is actually happening in those 20+ minutes may put you on the path to a solution.

 

Some of my preferred tools in this kind of situations:

  1. Good old Windows Performance Monitor.
    It can log a lot of information to file so it can be looked at a later time.
     
  2. Sysinternals Process Monitor.
    It can log to file a huge amount of data about what a process is doing, including errors.
    Be warned though, PM can generate a lot of load on the PC if you don't use filters.
    https://docs.microsoft.com/en-us/sysinternals/downloads/procmon
     
  3. HWiNFO64.
    In Sensor View it can log to file what is happening with a lot of the hardware in a system.
    https://www.hwinfo.com

    This file can later be viewed with GenericLogViewer (a little bit down on this page):
    https://www.hwinfo.com/add-ons/

 

Hope this helps.

 

Good luck
OaS

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, Linciano said:

Hello there! :)

 

Were you able to solve your issue with the suggestions given above?

Kindly let us know, so we can keep the Forum always organized.

I await your return.

 

Kind regards

Linciano

TruckersMP Support

negative, or not with any surety.  I installed the monitors described above and, sure as heck, the game loaded in 20 seconds flat....which is NOT normal.  take the monitors off, takes forever.

 

IUn the meantime, I just upgraded my system to a MSI B570, AMD 3700X and 32G of DDR4-3200 RAM (SIGNIFICANTLY faster machine) today so haven't had a chance to try it to see if the rapid load becomes the norm.  will update as soon as I find out.

 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Hello there,

 

Seeing as there was sadly no replies in the past 3 days, we must take action on this forum topic. Please keep in mind that we strive to offer a clean and organized forum for our users and this therefore requires us to close inactive topics.

 

As a result, we will be closing this topic, however, you may contact me to have this topic reopened if you would like.

 

// Locked and moved to inactive

 

Kindest Regards,

TFM DJ ccowie

TruckersMP Support

Edited by Beenz.

Share this post


Link to post
Share on other sites
  • 0

Hello again,

 

As we have noticed that you have not gotten in touch with the Support Team regarding this topic for a week, this topic no longer seems needed.

 

As a result, we will be taking further actions which will be final.

 

// Moved to Unsolved.

 

Kindest Regards,

TFM DJ ccowie

TruckersMP Support

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...