Jump to content
  • 0
LukxiAUT

My Ets2 version won´t change

Question

Hello Guys!

 

So my problem: 

When i´m trying to start The Game (TruckersMP not the Singleplayer) It says unsupported version. I already tried every Version from the Game and it still doesn´t work 

 

Please help me and Merry X-mas! 

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hello,

 

This article may help you: https://truckersmp.com/knowledge-base/article/26

To play our mod you have to set:

For ATS select: temporary_1_36 - 1.36.x

For ETS2 select: NONE - Opt out of all beta programs

 

Also you can check when game version has been changed here:

 

 

Kind Regards,

JJay

TruckersMP Support

  • Like 1

Share this post


Link to post
Share on other sites
  • 1

Dear @LukxiAUT,

 

If you can't update TruckersMP launcher;

1-Open the launcher as administrator

2-Press F1

3-Select Install Available Updates.

 

If it's not working;

1-Download Ultrasurf.

2-Run Ultrasurf.

3-Open TruckersMP in Administrator Mode.

4-Install the available updates (only the first run with Ultrasurf), wait for it to finish and Launch button appears.

5-Exit/Close Ultrasurf.

 

If you can't update Euro Truck Simulator 2;

1-Go to the Steam Library,

2-Press right click on Euro Truck Simulator 2 and click properties,

3-A small gray window will open and select Betas,

4-Select NONE - out of all beta programs

 

Also try to verify your game;

1-Go to Steam Library

2-Right click Euro Truck Simulator 2

3-Properties

4-Local Files

5-Verify Integrity of Game Files

 

Best Regards,

Next7

 

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0
25 minutes ago, JJay said:

Hello,

 

This article may help you: https://truckersmp.com/knowledge-base/article/26

To play our mod you have to set:

For ATS select: temporary_1_36 - 1.36.x

For ETS2 select: NONE - Opt out of all beta programs

 

Also you can check when game version has been changed here:

 

 

Kind Regards,

JJay

TruckersMP Support

In my case it still keeps claiming i'm using version 1.34, and i only have ETS2 installed.
Upgrading and downgrading versions is nothing new to me, but for the first time the MP launcher keeps on insisting i'm using the old version.
Also updating the MP launcher with F1 does nothing either. 
It just "updates", but keeps on giving me the version error.
Theres not much more i can do,  changing the ETS2 versions doesen't help, updating the MP launcher does nothing, re-installing the MP does nothing.
And on a side note did reply here once before but seems that it wasn't approved

*edit before posting*

Your MP launcher version is 1.0.0.4 instead of 1.0.0.5 when downloaded from the  https://truckersmp.com/download,.
Mayhap this is the reason the version check keeps failing?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...