Jump to content
  • 0

Lower FPS


6 answers to this question

Recommended Posts

  • 0

Hello @Roelvink!

I experience this too, its when you go near a populated area. When in range of other players, TMP starts to import all the models into your game, you cant see them due to your distance, but they are there, causing the game to lower in FPS.

The best thing you can do which you done already is lower your quality settings, or even use gamemode provided in Windows 10, Avast (In the Avast Anti-Virus software) or GeForce Experience (If your using a NVIDIA GeForce GPU). Another thing you can do is go to your TMP settings in game (Tab > Right click > Gameplay (I think) > Player range (I think)) to lower your player loading range, this can help with your FPS issues too due to if the players are 500 metres away and you got it set to 300 metres, the players wont load in, reducing the models being imported, increasing FPS. It sounds really confusing but I hope you get it.

Share this post

Link to post
Share on other sites
  • 0


Try these:

Press your Tab button -> go to Settings,

Uncheck Load Cabin Accessories and Use Fast Loading of models,

General -> Development Logging -> Disable,

Drivers animation -> Disable,

After you did that just click on Apply and ok -> Restart your Game,

You can see 2 pictures


Keep the display board up to date.

Make sure that an application that forces the processor does not work in the null,

As you enter the game, you may find it easier to play the game by closing the antivirus and unnecessary programs,

Delete useless folders with ccleaner or clean master of pc programs,

Take care not to play in busy areas(Duisburg and calais city etc).

This topic will help you:


Also try this:

1. Going into the 'Set Launch Options' in the ETS2 and putting in this command:
-homedir g:\'
' being the name of the folder being created (you can change ' to whatever folder name you want)
2. Set g to whatever drive you have the game installed on. Launch the game. Shut it off. go to Documents\Euro Truck Simulator 2 and copy everything. Now go to g drive, or whatever you set it as, open the folder '
3. There will be a Euro Truck Simulator 2 folder in there, paste everything from the documents folder in there.
4. Now run the game, your save should be there, and hopefully it will run better.


The reason for this seems to be, if the game and the save file locations are on different hard drives, like mine were. Saves were in Documents/ folder on my C Drive and my game was installed on my G drive. If the saves are located on the same hard drive, things just run smoother. There are a lot of files being written to that folder in Documents it seems besides saves, so it's best if everything is on the same hard drive

  • Like 1
  • Thanks 1

Share this post

Link to post
Share on other sites
  • 0

Hello there,


Did you get the answer you were looking for with the answers given above?

Your confirmation of the status of your issue/question helps us keep the forum always organised! 


Kind Regards,  


TruckersMP Support

Share this post

Link to post
Share on other sites
  • 0

Dear @Heemse


Due to  your  topic has been inactive  for 3 days since the last reply,i will move your  topic  to Inactive Topics.

If you still need assistance,feel free to DM me or other support team members,we will open this again.


Thnaks for all participation!

Thnak you for your understanding!



//Locked and Moved to Inactive

Share this post

Link to post
Share on other sites
This topic is now closed to further replies.

  • Create New...