Jump to content
  • 0
PowerLK7

Speed Limit Disable

Question

5 answers to this question

Recommended Posts

  • 1

Hello there,

 

The speed limiter can be turned on and off in the settings of the game (Gameplay). However, it does not matter whether your speed limiter is on or off, you will always be limited to 56mph/90kmh when doing WoT contracts (external contracts) due to WoT settings which you cannot change.

If you are wanting to do above this speed limit (e.g. anywhere between 90kmh and 150kmh) I suggest you using the Freight Market, Cargo Market or Quick Jobs.

 

Hope this helps you!

 

Many thanks,

Callum.

 

 

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

This quote should help you and give some informations:

On 4/28/2018 at 11:08 AM, ismail [TR] said:

Hey there,

 

You need to do both of the following:

1-) Disable the speed limiter in your ETS2/ATS settings (Book Here)
2-) Disable the speed limiter in the TruckersMP tab menu (Book Here)
3-) You could join a server that has the speed limiter disabled completely after doing steps 1 & 2. (Optional)
4-) Steps 1 & 2 on a server with a speed limiter enabled it will limit you to 110kmh/68mph
5-) Any speed on External Contracts cannot go more than 90 km/h. 
* To go more than 90 km/h have to remove the limiter and taking those not speed game on External Contracts.

 

Kind Regards

JJay

Share this post


Link to post
Share on other sites
  • 0
13 minutes ago, Callum Johnson said:

Hello there,

 

The speed limiter can be turned on and off in the settings of the game (Gameplay). However, it does not matter whether your speed limiter is on or off, you will always be limited to 56mph/90kmh when doing WoT contracts (external contracts) due to WoT settings which you cannot change.

If you are wanting to do above this speed limit (e.g. anywhere between 90kmh and 150kmh) I suggest you using the Freight Market, Cargo Market or Quick Jobs.

 

Hope this helps you!

 

Many thanks,

Callum.

 

 

Cheers Callum, thought it could have been a bug in the first place but that answers that.

  • Thanks 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×