Jump to content
  • 0

Direct x11 changes back to 9


Question

Hi guys :) I downloadet the experimental beta 1.35 and tried to change the Direct x version from 9 to 11 but everytime I started the game I got an error message and the config.cfg changed back to Direct x9 :/

I checked my system I have Direct x 11 installed (Sapphire R9 380 Nitro capable of Direct x12)

I even installed the newest drivers. Since I installed the experimental 1.35 my mouse gets lags every few seconds I never had such problems before.

All graphics are on high/ultra.

 

I hope someone can help me :)

 

 

Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
Guest S̶ ̶p̶ ̶a̶ ̶r̶ ̶k̶ ̶i̶ ̶e̶

In your ets2 steam launch options try adding -rdevice dx11 as well as changing the config file

To fix your mouse, also try adding -dinput_async_period 0 to the launch options in steam

Link to post
Share on other sites
  • 0

Hello @-Daniel- look this:

https://forum.scssoft.com/viewtopic.php?f=41&t=271284&start=20#p1138581

Quote

Go into your config.cfg file and change

uset r_device "dx9"

to

uset r_device "dx11"

It is still unstable, so it has some bugs.

 

Remember that this is experimental_beta. Check also this information about the experimental_beta: https://forum.scssoft.com/viewtopic.php?f=41&t=271284#p1138514

Quote

...There's not as much of a risk, as a virtual certainty, that you'll meet bugs, kinks and instability - so think twice before you get in this Experimental Beta. Also, it's highly advised to use a completely new profile without ANY MODS - and backup your data before you enter.

...And remember to post your bug reports to the proper section, please.

 

 

Link to post
Share on other sites
  • 0
Guest S̶ ̶p̶ ̶a̶ ̶r̶ ̶k̶ ̶i̶ ̶e̶

Are you using Windows 7? They have said that Windows 7 doesn't have dx11 support yet.

Link to post
Share on other sites
  • 0
  • Translation Manager

Hello,

 

This is exactly the reason why it's a Experimental Beta. Things may have bugs, stuff can still go wrong, etc etc.

When you come across a bug, you should report it to SCS Software, not to us. We are TruckersMP, and we do not code ETS2 or ATS itself, just our mod. This new experimental beta therefore has got nothing to do with TruckersMP.

 

You can report bugs to SCS Software with this link:

https://forum.scssoft.com/viewtopic.php?t=16653

 

Sincerely,

Pillow

  • Upvote 1
  • True Story 1

Pillow | Translation Manager

Rules | Recruitment | Support | Feedback | Meet the Team | Guides | Suggestions

Link to post
Share on other sites
  • 0
On 5/7/2019 at 2:54 PM, S p a r k i e said:

Are you using Windows 7? They have said that Windows 7 doesn't have dx11 support yet.

Yes I am using Windows 7. Thx for answering :)

 

On 5/7/2019 at 6:35 PM, Soul Knight said:

Dear @-Daniel-

 

As the said above,I would like to know if your problem has been solved?

I await your return!

Sry for not answering earlier :) Yep after being informed that there isn't support for Windows 7 at the moment I just have to wait for the full version of 1.35

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...