Jump to content

Automatyczny relog z serwera oraz crash


Recommended Posts

Witaj @PawcioV6,

 

Po pierwsze, nie jest to błąd, ani problem z modyfikacją. Jest to problem dotyczący użytkowników, wiążący się z problemami z połączeniem internetowym, takimi jak utrata pakietów, uszkodzenie pakietów, bądź zła przepustowość sieci.

Jest to funkcja, która została dodana, aby uniknąć kolizji z powodu opóźnienia połączenia internetowego i uniknąć sytuacji, w której zostały zbanowane osoby, ponieważ wyglądało na to, że posiadają one NCZ hack, a w rzeczywistości mieli oni złe połączenie z serwerem.

 

Jednym ze sposobów na monitorowanie problemów z połączeniem jest wpisanie w konsoli g_developer 16. Aby je usunąć należy wpisać g_developer 1.

 

Powyższe polecenie spowoduje wyświetlenie poniższego panelu. Najbardziej interesującymi linijkami są: Packetloss last second oraz Packetloss total.

Optymalna wartość, to 0, ale jeśli widzisz, że te wartości rosną, powinieneś zacząć się martwić, że nie masz stabilnego połączenia.

R8tMyzK.png

 

Możliwe rozwiązanie:

Nie ma żadnego konkretnego rozwiązania tego problemu, które natychmiastowo naprawi ten problem, ale jest kilka rozwiązań, które pomogą uniknąć wyrzucenia z serwera.

  • Unikaj korzystania z Wi-Fi.
  • Unikaj pobierania/przesyłania i grania w trybie multiplayer w jednym momencie.
  • Unikaj aktualizacji Windows i grania w trybie multiplayer w jednym momencie.
  • Unikaj zbyt dużej ilości urządzeń/użytkowników podłączonych do sieci.
  • Unikaj przesyłania strumieniowego i grania w trybie multiplayer w jednym momencie.
  • Sprawdź ustawienia zapory w routerze/switchu.
  • Preferuj korzystanie z serwerów znajdujących się najbliżej Twojej lokalizacji.
  • Spróbuj porozmawiać ze swoim usługodawcą internetowym i znaleźć rozwiązanie tego problemu.

 

Z poważaniem,

EPS!LON

Link to post
Share on other sites

@PawcioV6 Czyli problem występuje w przypadku zwykłego neta, jak i z telefonu?

W takim wypadku proponowałbym posprawdzać ustawienia sieciowe w komputerze.
Od kiedy zaczęły się tego typu problemy? Jakaś konkretna instalacja programu/gry? Zmiany w ustawieniach Windows?

Posiadasz jakąkolwiek inną, online'ową grę (np. LoL), która pokazuje w czasie rzeczywistym ping? Jeżeli tak - są częste lagi?

Devil.png.25b4bc50511b4c18e1d94787505233c9.png

Link to post
Share on other sites

@David Tylko tutaj (Czyt. Truckers MP) pojawił się problem odkąd założyłem temat pierw chodziło dobrze. Tak gram w gry online WoT czy MTA i nie mam problemów z pingiem, pokazuje mi zawsze taki mam MTA 30-40 (sewer) słabo stoi z optymalizją przynajmniej na którym ja gram, Wot tak od 30-100 zależy czy mam film na telefonie odpalony czy nie. Ogólnie biorąc to mi się wydaje, że coś jest z samą aplikacją gdyż nie tylko ja mam taki problem. No chyba że ja jednak mam coś z ustawieniami, chodź ja nic nie zmieniłem w komputerze. Dostawca to T-Mobile jak Wi-Fi i telefonu spróbuje jeszcze karty z PLAY jeżeli problem będzie dalej występować to ja już nie wiem.

Link to post
Share on other sites

@PawcioV6 możesz nam podać specyfikacje komputera?

I czy na tym samym komputerze, grałeś już na TruckersMP? I ewentualnie jeżeli masz taka możliwość spróbuj na innym komputerze zainstalować grę, launcher i spróbuj się połączyć ponownie z serwerem, będąc oczywiście ciągle połączonym z ta sama siecią.

 

Spróbuj jeszcze z poziomu konsoli (cmd) wykonać test pingu do serwera EU2.

ping 151.80.230.152 -t i zerkaj czy jest stabilnie czy jednak wywala inne komunikaty.

 

 

//Specyfikacje można ujrzeć na drugim Screenie //LamAll
//Dziekuje nie zwrocilem uwagi. //wpx

"You seemed like the ,,veteran” that knows everything. Not like a war veteran, just a guy that was long enough to know how it works"

Link to post
Share on other sites

 "Niby wszystko pod komendą "ping..." sprawdziłem nic się nie rozłączy w konsoli podczas tego błędu."~6 komentarz od góry, 4 od dołu. Grałem ma nim już i brak błędów. Specyfikacja widoczna w plikach "pastebin", ale ok. Nie mam innego komputera który uruchomi ETS'a. Chyba wyczerpałem maksymalnie Twój komentarz @wpx_

Link to post
Share on other sites

@PawcioV6 Spróbuj odinstalować całkowicie TruckersMP, wraz z folderem instalacyjnym, a także w folderze ProgramData usuń folder "TruckersMP" - później na nowo zainstaluj TruckersMP i daj znać, czy coś przynajmniej z tego wyszło :)

A jeżeli problem nadal istnieje - nie masz przypadkiem jakiegoś moda? Albo nowy profil utwórz i spróbuj na nowym wejść na multi.
Czekam na odpowiedź!

Devil.png.25b4bc50511b4c18e1d94787505233c9.png

Link to post
Share on other sites
  • Web Developer

Witaj @PawcioV6,

 

W związku z tym, że ten temat nie był aktywny przez ostatnie 3 dni, przenoszę go do nieaktywnych tematów.

Jeżeli nadal potrzebujesz pomocy, skontaktuj się z nami za pomocą Systemu Ticket.

 

Z poważaniem,
Kid Fabi
TruckersMP Support Team

 

// Zamykam i przenoszę do nieaktywnych tematów

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...