Jump to content
Diar_PL

Wersja Developerska

Recommended Posts

Witam

Wiem, że temat wałkowany ale po przeczytaniu kilkunastu stron tematów niestety nie znalazłem odpowiedzi na tyle jasnej, żeby mi pomogła.
Przy uruchomieniu gry, nie ważne czy single player normalnie czy safe mode, multiplayer przez launcher'a czy Truckbooks wyskakuje mi informacja o narzędziach developerskich.
Nie przeszkadza mi to ale... jeśli wywali mnie z serwera za AFK i loguje się ponownie - resetuje mi trasę z uwagi na wykryte zmiany w grze. Podobnie na Single player - jeśli wyłączę gre i ponownie wejdę - reset trasy, zestaw w garażu.

Używam jedynie Truckbooks i wcześniej miałem moda frosty no i odpaloną konsolę dla resetowania ekonomii.

Przywróciłem cfg do stanu pierwotnego (console i admin developer na "0") i usunąłem moda (poprzez wykasowanie go z folderu mod).
Teoretycznie mam grę "czystą" bez żadnych dodatków poza oryginalnymi DLC.

Jaka może być przyczyna i jak się pozbyć tego problemu?

Dzięki z góry za jakiekolwiek rady.

Pozdrawiam

Grzegorz

Share this post


Link to post
Share on other sites

Ok,

już wiem,

Truckbooks ingeruje w grę i wyświetla się ten komunikat.
Tylko czemu po wyjściu i powrocie do gry resetuje mi dostawę i przenosi do garażu ?
 

EDIT: najwyraźniej powód jest już znany. Szkoda że dostawy resetuje (ostatnie 3 z 5). Do zamknięcia no chyba że ktoś ma jeszcze rady i/lub sugestie

 

Share this post


Link to post
Share on other sites

Załącz logi z pliku game.log.txt, może tam dowiemy się co to powoduje? Pluginy w ogóle nie powinny ingerować w grę jako tako więc nie szukałbym tutaj problemu.

Share this post


Link to post
Share on other sites
6 hours ago, WooQash said:

Załącz logi z pliku game.log.txt, może tam dowiemy się co to powoduje? Pluginy w ogóle nie powinny ingerować w grę jako tako więc nie szukałbym tutaj problemu.

 

Zrobiłem czystą instalację i po uruchomieniu truckbooks wyskoczył błąd ponownie. Więc na pewno truckbooks wywala komunikat.
Okazuje się że w katalogu gry, tj \steamapps\common\Euro Truck Simulator 2\bin\win_x64\plugins mam plik z truckbook_64.dll
Czyli jednak ingeruje w grę i ot - jest przyczyna

Share this post


Link to post
Share on other sites

Tylko, że u innych stosujących Truckbook raczej czegoś takiego nie ma, więc nadal coś jest nie tak. Czysta instalacja to nie wszystko, a folder w dokumentach? On jest też ważny, bo zawiera całą konfigurację.

Share this post


Link to post
Share on other sites
Posted (edited)

Wyczyściłem wszystko. Poza wpisami do rejestru.
Jestem w fazie testów.
Defacto zaczeło się krzaczyć po wejściu 1.34 (a dalej miałem frosty moda).
EDIT:
No i póki co działa. 
Problem rozwiązany:
1. Reinstalka gry i multiplayera pomogła + usunięcie plików io folderów z dokumenty/Eurotruck oraz z folderu STEAM (warto zabezpieczyć katalog z profilem :) )
2. Po przejściu na 1.34 i usunięcie manualne moda z katalogu było głupie i spowodowało wywalanie problemu wyżej opisanego dotyczącego resetu dostawy - myślę że usunięcie go poprzez grę byłoby lepszym pomysłem i zadziałało by jak należy.

Do zamknięcia, dzięki

Edited by Diar_PL
rozwiązanie problemu

Share this post


Link to post
Share on other sites

Witam @Diar_PL

 

Cieszymy się, że mogliśmy Ci pomóc.

W razie dalszych pytań napisz do mnie w prywatnej wiadomości.

Problem został rozwiązany .

 

// Zamykam i przenoszę do Archiwum na prośbę autora.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×