Jump to content
  • 0
jokkeman66

Error message | Connection error - Retry?

Question

Hello! 

 

I have been having this problem for over a month, where I'm just getting an error message. I have tried deleting the .dll files to see if that worked, but it didn't. I have tried launching the mod in administrator, but with no luck. I have also reinstalled the mod about 15 times, deleted all TruckersMP files to reinstall but that hasn't worked either. I'm all out of ideas. People with the same problem managed to fix this by reinstalling, but it just doesn't work for me.

 

image.png.8d75b24ef053a89f34fa5bd0523c52dd.png

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Hello, Would you try these solutions?

Solution 1:

  • Access the Control Panel
  • Type "folder" into the search bar and select Show hidden files and folders.
  • Then, click on the View tab at the top of the window.
  • Under Advanced Settings, locate "Hidden files and folders." Select Show hidden files and folders just below that.
  • Click on apply and ok this window close.
  • Now go to Local Disk C > ProgramData > TruckersMP
  • In this directory, "core_ets2mp.dll" delete file.
  • Open TruckersMP in administrator mode.
  • Click update button and little after update finished Launch ETS2.

Solution 2:

  • Use a VPN.
  • Download Ultrasurf or Windscribe
  • Run Ultrasurf or Windscribe
  • Connect to a server in Ultrasurf or Windscribe, then click On button.
  • Open TruckersMP in administrator mode.
  • Install the available updates.
  • Exit Ultrasurf or Windscribe.

Solution 3:

  • Press the Windows Key + R (Win+R) on your keyboard
  • Enter "%programdata%" and press Enter (without the quotes)
  • Find the folder "TruckersMP" and delete that folder.
  • Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
  • Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/
  • Open The Launcher with admin privileges and click "Install Available Updates

Kind Regards,

mexiumut

Share this post


Link to post
Share on other sites
  • 0

Dear @jokkeman66,

 

In order, to fix this problem I recommend you to follow the next steps:
> Make sure you have the latest .Net Framework
> Clean your temp files with CCleaner
> Check your temp files path and make sure it's located at C:\Users\name\AppData\Local\Microsoft\Windows\INetCache
> If you don't have "INetCache" folder make a new folder and name it "temp" and then open the Windows temp settings and choose the new path by clicking on Move folder...

If the above steps didn't work for you, open Command Prompt as admin and type net user Administrator /active:yes .This will activate the built-in Administrator account.
> Log out your account and log in the Administrator account.
> Open TruckersMP launcher and install the updates. Try to launch the game and see it if works.
> Log out again and log back in with your normal account.
> If you still have the same error you can keep playing from the Administrator account as a temporary solution.

 

Kind Regards,
BL4CK$K1LL
TruckersMP - Trial Support

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, jokkeman66 said:
2 hours ago, BL4CK$K1LL said:

Dear @jokkeman66,

 

In order, to fix this problem I recommend you to follow the next steps:
> Make sure you have the latest .Net Framework
> Clean your temp files with CCleaner
> Check your temp files path and make sure it's located at C:\Users\name\AppData\Local\Microsoft\Windows\INetCache
> If you don't have "INetCache" folder make a new folder and name it "temp" and then open the Windows temp settings and choose the new path by clicking on Move folder...

If the above steps didn't work for you, open Command Prompt as admin and type net user Administrator /active:yes .This will activate the built-in Administrator account.
> Log out your account and log in the Administrator account.
> Open TruckersMP launcher and install the updates. Try to launch the game and see it if works.
> Log out again and log back in with your normal account.
> If you still have the same error you can keep playing from the Administrator account as a temporary solution.

 

Kind Regards,
BL4CK$K1LL
TruckersMP - Trial Support

 

3 hours ago, mexiumut said:

Hello, Would you try these solutions?

Solution 1:

  • Access the Control Panel
  • Type "folder" into the search bar and select Show hidden files and folders.
  • Then, click on the View tab at the top of the window.
  • Under Advanced Settings, locate "Hidden files and folders." Select Show hidden files and folders just below that.
  • Click on apply and ok this window close.
  • Now go to Local Disk C > ProgramData > TruckersMP
  • In this directory, "core_ets2mp.dll" delete file.
  • Open TruckersMP in administrator mode.
  • Click update button and little after update finished Launch ETS2.

Solution 2:

  • Use a VPN.
  • Download Ultrasurf or Windscribe
  • Run Ultrasurf or Windscribe
  • Connect to a server in Ultrasurf or Windscribe, then click On button.
  • Open TruckersMP in administrator mode.
  • Install the available updates.
  • Exit Ultrasurf or Windscribe.

Solution 3:

  • Press the Windows Key + R (Win+R) on your keyboard
  • Enter "%programdata%" and press Enter (without the quotes)
  • Find the folder "TruckersMP" and delete that folder.
  • Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
  • Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/
  • Open The Launcher with admin privileges and click "Install Available Updates

Kind Regards,

mexiumut

I have now done all of these/ the ones I had not done already and I still get the same error.

 

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Sentinel_ said:

Run TruckersMP in compatibility mode for Windows Server 2008 / Windows 7 or Windows 8 and see if it works. Also run as admin.

This didn't work either :( Well, I tried compatability mode for Windows 7 and 8, it didn't give me the option for Windows Server 2008.

 

Share this post


Link to post
Share on other sites
  • 0

Hello There!

 

Your topic has been inactive for 3 days since the last reply.
Because of inactivity, I will have to move this topic to Inactive Topics.


If you still have any questions about this, feel free to DM me or our support team members, we will open this again.
Thanks to all for participation!

 

//Locked and Moved to Inactive

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...