Jump to content
  • 0

Black Screen.


Lbs207

Question

23 answers to this question

Recommended Posts

  • 0

hi @Lbs207

 

 

4 minutes ago, Lbs207 said:

After reinstalling my game, I launch it and it is just black screen. Nothing else. Help. The support area of MP is not doing anything so I’m completely clueless.

 

 

 

Run TruckersMP launcher as Administrator

If the above doesn't work for you, press WIN+R keys and type %programdata% then delete TruckersMP folder

 

 

regards,

[WTCC_GR] Sergios

 

Link to post
Share on other sites
  • 0

Try running TruckersMP as an administrator also:

 

1. Right click ETS 2 in steam

2. Select 'Launch with OpenGL'

3. Let the game run and try going into game.

4. Exit the game and go back to steam, right click ETS 2 again but this time select 'Launch with DirectX (64-Bit)

5. Again go into game and then exit.

6. Start TruckersMP up

Link to post
Share on other sites
  • 0

Other games working?

 

1. reinstall graphics card driver

2. steam --> euro truck --> properties --> verify game files

3. look picture and try start game safe mode or try all them

(steam library right click euro truck 2)

start game.jpg

 

4. if you have two screens or more take them away

Link to post
Share on other sites
  • 0
5 hours ago, LaserX said:

Hey, have you tried verifying the integrity of game files option in the properties of ETS2 on Steam?

 

Screenshot_6.png.4fed795b0be992fe565b0e3ac03ca56e.png

Sort of, It just froze and did nothing. I’ll make sure to try again if these others don’t work!

 

5 hours ago, nissam said:

Other games working?

 

1. reinstall graphics card driver

2. steam --> euro truck --> properties --> verify game files

3. look picture and try start game safe mode or try all them

(steam library right click euro truck 2)

start game.jpg

 

4. if you have two screens or more take them away

Yes, Other games working. CSX Heavy Haul 60 FPS Same for Fernbus. All maxed out settings.

Just updated graphics card when this started though.

I’ll make sure to try out all launch methods!

5 hours ago, Kamer said:

Hello there,

You must follow steps

 Try updating your display card.

• Login with a new profile.

• If you have your own profile, delete the Config file and enter the game again.

Display card just got updated, I’ll try the config delete if none of these work!

6 hours ago, Sentinel_ said:

Try running TruckersMP as an administrator also:

 

1. Right click ETS 2 in steam

2. Select 'Launch with OpenGL'

3. Let the game run and try going into game.

4. Exit the game and go back to steam, right click ETS 2 again but this time select 'Launch with DirectX (64-Bit)

5. Again go into game and then exit.

6. Start TruckersMP up

I’ll try this! I did try the OpenGL but then I didn’t launch with DirectX.

6 hours ago, [WTCC_GR] Sergios said:

hi @Lbs207

 

 

 

 

Run TruckersMP launcher as Administrator

If the above doesn't work for you, press WIN+R keys and type %programdata% then delete TruckersMP folder

 

 

regards,

[WTCC_GR] Sergios

 

Sadly this is a singleplayer issue too. I’ll still try this though because it could be MP Messing it up!

—————

Thank you so much for answering! I will try these as soon as I can! This amount of support is what makes this community amazing!

Link to post
Share on other sites
  • 0
On 1/2/2019 at 3:30 PM, Sentinel_ said:

Try running TruckersMP as an administrator also:

 

1. Right click ETS 2 in steam

2. Select 'Launch with OpenGL'

3. Let the game run and try going into game.

4. Exit the game and go back to steam, right click ETS 2 again but this time select 'Launch with DirectX (64-Bit)

5. Again go into game and then exit.

6. Start TruckersMP up

Yes! Launching in DirectX works! Sadly it lags a ton! I’ll try verifying the game files as others have suggested!

Link to post
Share on other sites
  • 0
23 hours ago, nissam said:

Other games working?

 

1. reinstall graphics card driver

2. steam --> euro truck --> properties --> verify game files

3. look picture and try start game safe mode or try all them

(steam library right click euro truck 2)

start game.jpg

 

4. if you have two screens or more take them away

Ah Yes! Safe mod works too! Although I will have to redo all my settings atleast it works! 

 

I want to thank everyone for helping me fix my issue! Thank you so much!!

Link to post
Share on other sites
  • 0
1 hour ago, Lbs207 said:

Well i still have a ton of lag but now in multiplayer. Turning settings down won’t help. 

 

Make sure you press apply.

 

Today i couple times changing video settings to lower but didnt help because i didnt press apply :D

 

Defrag your hard drives if you have HDD drive and check gpu/cpu temperatures when you playing.

 

Write your computer specs here.

 

 

 

Link to post
Share on other sites
  • 0
10 hours ago, nissam said:

 

Make sure you press apply.

 

Today i couple times changing video settings to lower but didnt help because i didnt press apply :D

 

Defrag your hard drives if you have HDD drive and check gpu/cpu temperatures when you playing.

 

Write your computer specs here.

 

 

 

Everything is perfectly fine.

I’m running the settings what my computer should be easily handling. 

Except it’s not.

Easily handing as in 60 FPS amazing graphics.

Example: Fernbus. Maxed settings at 60 FPS.

No matter what I do in ETS2 it just will not work.

I’m wondering if there’s any console command to fix or if I should just completely reinstall the game.

 

Link to post
Share on other sites
  • 0
9 minutes ago, Lbs207 said:

Desktop, i7-8700k + Nvidia RTX 2080

I hope this helps.

Try to re-install your graphics drivers.

 

Use DDU https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

 

Click 'Clean and Restart' in the app. 

 

Before you do that download the latest drivers from https://www.geforce.co.uk/drivers to somewhere like your desktop, ready to install when the computer restarts after uninstalling the current drivers. 

Link to post
Share on other sites
  • 0
10 minutes ago, Sentinel_ said:

Try to re-install your graphics drivers.

 

Use DDU https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

 

Click 'Clean and Restart' in the app. 

 

Before you do that download the latest drivers from https://www.geforce.co.uk/drivers to somewhere like your desktop, ready to install when the computer restarts after uninstalling the current drivers. 

I installed the latest driver which was Nvidia GeForce Experience because apparently the other drivers aren’t actually wanting to install and it jus told me to download GeForce Experience.

Which I did a clean install and it got rid of my other Nvidia driver which wasn’t GeForce Experience and was outdated. It also didn’t open its control panel.

Then ETS2 stopped working.

I’ll try probably Sunday to download the driver that it got rid of and see what happens!

Link to post
Share on other sites
  • 0
Guest K-The29
On 1/2/2019 at 9:10 PM, Lbs207 said:

After reinstalling my game, I launch it and it is just black screen. Nothing else. Help. The support area of MP is not doing anything so I’m completely clueless.

 

Hey

You should reinstall window to fix the issue.

It's only the fix that can fix your issue.

 

Regards

K-The29

Link to post
Share on other sites
  • 0

Oh! Got you! I’ll try that if that’s the last resort! 

On 1/5/2019 at 7:47 AM, Sentinel_ said:

Try to re-install your graphics drivers.

 

Use DDU https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

 

Click 'Clean and Restart' in the app. 

 

Before you do that download the latest drivers from https://www.geforce.co.uk/drivers to somewhere like your desktop, ready to install when the computer restarts after uninstalling the current drivers. 

I’ll try this overnight. WiFi so bad it takes a couple hours just to download this.

Link to post
Share on other sites
  • 0

Control panel says I need to install control panel through GeForce Experience which is literally not possible. 

Just going to reinstall my game at this point. 

If the lag continues I’m going to put it back on my smaller but faster C drive and put ATS into the bigger but slower D drive because I don’t really play it.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...