Jump to content
  • 0
MihneaGG

ets2 mp stopped working

Question

Hello, i have this problem with the ets2 mp.Everytime i click on it it says truckers mp launcher  has stopped working.I don t know what to do.Pls help me.I bought the game from steam and install it, then i install several time the ets2 mp but nothing, the same problem, it doesn t open.Pls help!!

Screenshot_4.png

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 1

Hello MihneaGG,

 


Please read this carefully:
1-) Go to Steam Library
2-) Right click Euro Truck Simulator 2
3-) Properties
4-) Local Files
5-) Verify integrity of game files
6-) Wait for the process to complete then Re-Attempt to launch ETS2
+ Ensure you launch ETS2 in DirectX mode via SinglePlayer, then launch Multiplayer

 

KindRegards,

InvisibleRaptor

TrialSupport

Share this post


Link to post
Share on other sites
  • 0

Dear @MihneaGG ,


I am going to move your topic to help since you're looking for help. Next time, if you have any questions related to TMP, please create a topic in the help section
You can find the help section over here https://forum.truckersmp.com/index.php?/forum/55-help/


The "General Discussion" section is for discussions related to the game ETS2 or ATS2 but not for help related stuff.

 
If you have any further questions feel free to send me a private message.

//Moved to Help

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, InvisibleRaptor said:

Hello MihneaGG,

 


Please read this carefully:
1-) Go to Steam Library
2-) Right click Euro Truck Simulator 2
3-) Properties
4-) Local Files
5-) Verify integrity of game files
6-) Wait for the process to complete then Re-Attempt to launch ETS2
+ Ensure you launch ETS2 in DirectX mode via SinglePlayer, then launch Multiplayer

 

KindRegards,

InvisibleRaptor

TrialSupport

Hi, i tried, it didn t work 

 

22 minutes ago, LeRenard said:

Hello ,

 

Have you updated your drivers?
Have you tried to uninstall and reinstall?
Have you put the right location of your game?

 

Sign

LeRenard

I unnistalled and then installed but the same problem. Whrn i installed the game i installed it in C program files X86 steam steamapps common and euro truck 2.I don t know if i installed it corectly, i mean in the right compartiment. Where did u installed it?

 

Share this post


Link to post
Share on other sites
  • 0

 

Because your problem is not solved, please try these steps: 

 

Firstly start by restarting your PC and running the launcher as administrator. If that doesn't work, please try the following steps.

1.) Press the Windows Key + R (Win+R) on your keyboard
2.) Enter "%programdata%" and press Enter (without the quotes)
3.) Find the folder "TruckersMP" and delete that folder.
4.) Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
5.) Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/
6.) Open The Launcher with admin privileges and click "Install Available Updates"

I look forward to hearing from you!

 

Sincerely,
InvisibleRaptor

TrialSupport

Share this post


Link to post
Share on other sites
  • 0
18 minutes ago, InvisibleRaptor said:

 

Because your problem is not solved, please try these steps: 

 

Firstly start by restarting your PC and running the launcher as administrator. If that doesn't work, please try the following steps.

1.) Press the Windows Key + R (Win+R) on your keyboard
2.) Enter "%programdata%" and press Enter (without the quotes)
3.) Find the folder "TruckersMP" and delete that folder.
4.) Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
5.) Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/
6.) Open The Launcher with admin privileges and click "Install Available Updates"

I look forward to hearing from you!

 

Sincerely,
InvisibleRaptor

TrialSupport

I followed all the steps and unfortunately it doesn t work. Thank you for your support, i apreciate it. I have no idea why it doesn t work. 

Share this post


Link to post
Share on other sites
  • 0

 

Dear @MihneaGG,

 

Can you try this ?:)

 

---First---

> Go to Steam Library

> Right click Euro Truck Simulator 2

> Properties

> Local Files

> Verify the integrity of game Files

--- Second ---

> Open your steam client

> Library

> ETS 2

> Click "Play"

> Choose "Launch with DirectX (64-bit).

> Choose your profile and press "drive"

> Close ETS 2

--- Third ---

> Update your graphic card driver.

> Not be placed on busy area like Calais, or Duisburg > pull down your graphics settings.

> Check if you have not a lot of "Drivers" on your company.

 

Looking forward to hearing from you,

 

Kind regards,

King^

TruckersMP - Support

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, King^ said:

 

Dear @MihneaGG,

 

Can you try this ?:)

 

---First---

> Go to Steam Library

> Right click Euro Truck Simulator 2

> Properties

> Local Files

> Verify the integrity of game Files

--- Second ---

> Open your steam client

> Library

> ETS 2

> Click "Play"

> Choose "Launch with DirectX (64-bit).

> Choose your profile and press "drive"

> Close ETS 2

--- Third ---

> Update your graphic card driver.

> Not be placed on busy area like Calais, or Duisburg > pull down your graphics settings.

> Check if you have not a lot of "Drivers" on your company.

 

Looking forward to hearing from you,

 

Kind regards,

King^

TruckersMP - Support

i tried, it doesn t work.I don t know what to do to make it work

Share this post


Link to post
Share on other sites
  • 0

Dear @MihneaGG

 

I can see you have marked the best answer so has your problem been solved?

 

Your confirmation of the status of your issue helps us keep the forum alaways organized!

 

I await your return!

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, Soul Knight said:

Dear @MihneaGG

 

I can see you have marked the best answer so has your problem been solved?

 

Your confirmation of the status of your issue helps us keep the forum alaways organized!

 

I await your return!

Hello,my problem isn t solved !!

Share this post


Link to post
Share on other sites
  • 0

Hello :)

Have you got the latest .NET Framework installed?

https://www.microsoft.com/en-us/download/details.aspx?id=53344 

 

If you have, then please try using the .NET Repair Tool:

https://www.microsoft.com/en-gb/download/details.aspx?id=30135 

 

Also, install the latest C++ Version:

https://www.microsoft.com/en-us/download/details.aspx?id=48145 

 

And try these

Solution 1:

1. Start a command line as an administrator (cmd)

2. Run the command:

 

sfc /scannow

 

3. Wait, and then restart your computer

4. Run a single game in x64 DirectX mode (Launch witch DirectX for ATS)

5. Drive a short distance

6. Exit Game

7. Start multiplayer

 

Solution 2:

Have you tried running TruckersmP as an administrator?

- Right click on TruckersMP 
- Click run as an administrator

Have you tried troubleshooting?

- Right click on TruckersMP
- Click troubleshoot

 

Solution 3:

Right click on TruckersMP > Compatibility > Run the program as administrator > apply & ok > start the Launcher 

if it doesn't work then delete the following file - C: > ProgramData > TruckersMP > "core_ets2mp.dll" (or just search for %programdata% > TruckersMP >  "core_ets2mp.dll"). Launch TruckersMP and see if it works.

 

And read these topics

 

 

 

Share this post


Link to post
Share on other sites
  • 0
15 hours ago, [ETS2MCG] Kien Giang said:

Hello :)

Have you got the latest .NET Framework installed?

https://www.microsoft.com/en-us/download/details.aspx?id=53344 

 

If you have, then please try using the .NET Repair Tool:

https://www.microsoft.com/en-gb/download/details.aspx?id=30135 

 

Also, install the latest C++ Version:

https://www.microsoft.com/en-us/download/details.aspx?id=48145 

 

And try these

Solution 1:

1. Start a command line as an administrator (cmd)

2. Run the command:

 

sfc /scannow

 

3. Wait, and then restart your computer

4. Run a single game in x64 DirectX mode (Launch witch DirectX for ATS)

5. Drive a short distance

6. Exit Game

7. Start multiplayer

 

Solution 2:

Have you tried running TruckersmP as an administrator?

- Right click on TruckersMP 
- Click run as an administrator

Have you tried troubleshooting?

- Right click on TruckersMP
- Click troubleshoot

 

Solution 3:

Right click on TruckersMP > Compatibility > Run the program as administrator > apply & ok > start the Launcher 

if it doesn't work then delete the following file - C: > ProgramData > TruckersMP > "core_ets2mp.dll" (or just search for %programdata% > TruckersMP >  "core_ets2mp.dll"). Launch TruckersMP and see if it works.

 

And read these topics

 

 

 

Hi, it s working now. Thanks for your help

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×