Jump to content
  • 0

not connecting to truckersmp and the stop lights are not changing


Question

11 answers to this question

Recommended Posts

  • 0

Hello @Mr-Squirrel,

 

Please, could you attach a screenshot, just so we can verify the exact issue you are experiencing? 

 

As well as the above, it would be helpful if you can attach your results from the speed test found here: http://beta.speedtest.net/

 

For the meantime, try this solution by following the steps regarding 'flushing your DNS':

> Press Start or the Windows icon via your desktop task pane
> Search for "cmd"
> Right click the "cmd" icon and select "Run as Administrator"
> Within cmd - Type this command: "ipconfig /flushdns"  (Without any quotation " " marks)
> Wait for this to complete. 
> Relaunch MP

 

Note: Remember to always launch the TruckersMP launcher with administrator privileges: 

> Right click the launcher

> Properties

> Compatibility

> Tick/check the box saying 'run this program as administrator' 

 

It seems you have enabled the launcher through your firewall, however, please confirm with me whether or not you have made an exception through your anti-virus software as well. 

TruckersMP Game Moderator Leader

Pries Logistics - Founder

———————————————

Languages: gb.gif | ru.gif | ge.gif

Rules | Recruitment | Support | Feedback | Meet the Team | Knowledge Base

———————————————————————————————————————————————————————————————

 

Link to post
Share on other sites
  • 0

Hello, 

Is this exact the problem you're having?

 

7b2772e4caa548518f09ab6658390160.png

 

If yes, please try these steps.

 

Solution 1:

Turn off and on again the router. (Wait 5 minutes)

Stop any other updates that may use all your bandwidth. (Steam Updates, Origin Updates, Other browser updates)

Also make sure your Firewall/Antivirus is not blocking the launcher. Start by opening Windows Firewall and Restore defaults.

c0ab01c8ed1646078c9dfe10439a4d3b.png

 

 

Solution 2:

Clear your DNS address and use this DNS.

 

Clear DNS Address:

 

  • Right Click on the Start (Window) Icon
  • Click on Command Prompt
  • The Windows Command Prompt Window will appear.  Type in:

  • ipconfig /flushdns and press ENTER

  • You should receive the following message: Windows IP Configuration
    Successfully flushed the DNS Resolver Cache

Use DNS Address:

  • Open Control Panel.

  • Click on Network and Internet.

  • Click on Network and Sharing Center.

  • On the left pane, click on Change adapter settings.

  • Right-click the network interface connected to the internet, and select Properties.

  • Select Internet Protocol Version 4 (TCP/IPv4) from the list.

  • Click the Properties button.

  • Click the Use the following DNS server addresses option.

  • Here you can enter any DNS server.

  • Google Public DNS addresses:8.8.8.8 and 8.8.4.4

  • Click OK.

Now Open TruckersMP Launcher in administrator mode.

 

Also read this topic:

 

Kind Regards, 

mexiumut 

steam-512.png Steam Profile | spacer.png My ETS2 and ATS Mods blog for TruckersMP

 Supported  Languages: tr.gif Turkish and English en.gif

▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬

Volvo 750HP | Scania 750HP

Link to post
Share on other sites
  • 0

Hello :) 

It may cause by your internet

Try these to fix this problem

 

Have you tried to use VPN programs to play ?

 

Solution 1:

Solution 2:

1. Try turning your router off for 1 minute and then turning it back on and see if you still have connection problems

2. Try clearing your DNS cache, follow this link for the guide https://documentation.cpanel.net/display/CKB/How+To+Clear+Your+DNS+Cache

3. Try changing your DNS to Google's one and see if that has any effect https://www.techworm.net/2016/08/change-default-dns-google-dns-fast-internet-speeds.html

4. Try re-setting your win-sock cache 

 

Click on windows search program and type "cmd" enter (run cmd as an admin, right click run as admin)

Once you're in, type "netsh winsock reset catalog" enter

Type "netsh int ip reset.log hit" enter

Restart your computer

 

Reset your network adapter, firewall and DHCP.

 

This page will guide you through what you need to do and explains for different Windows operating systems as you scroll down. 

https://kb.wisc.edu/page.php?id=6653 

 

You type 

 

·         netsh int ip reset reset.txt

·         netsh winsock reset

·         netsh advfirewall reset

 

into a command prompt window

 

Also make your your internet doesn't block the connection 

 

And try this:

 

Link to post
Share on other sites
  • 0

Hello :)

This tends to happen when it's trying to connect (each time you load the game it'll attempt to connect) and if for whatever reason it takes so long that the connection attempt to the gameserver times out then it'll come up with the "broken" message. It's probably due to the heavy load and amount of connections that are trying to connect to the game.

 

Have you managed to connect at all? If you could give it a go this morning/later today and see if you're still getting that message.

 

Have you tried connecting in other server and still getting this error ?

 

And have you tried reinstalling TruckersMP launcher ?

Follow this:

  • Press the Windows Key + R (Win+R) on your keyboard
  • Enter "%programdata%" and press Enter (without the quotes)
  • Find the folder "TruckersMP" and delete that folder.
  • Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
  • Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/
  • Open The Launcher with admin privileges and click "Install Available Updates" 

If it still doesn't work, try these

Solution 1:

Verify the router or modem if the "UPNP" option is active, you usually find this option in the configures of your modem / router entering through the IP, for example: "192.168.1.1".

 

Solution 2:

1. Run the program as an administrator (right click the shortcut and select 'run as an administrator' and accept the UAC prompt.

2. Run TruckersMP in compatibility mode for Windows 7, please follow this guide http://pearsonsupport.helpserve.com/Knowledgebase/Article/View/210/21/how-to-install-or-run-a-program-in-compatibility-mode-in-windows-7

3. Install these two programs

Solution 3:

Make sure that you have steam open at the time of opening the mod and also make sure to check if there are any ETS 2 updates on steam, make sure that you download them.

You see that specific message is pertaining to the ETS 2 base game so this is an issue with the mod either not detecting that you have the latest version installed or something else is bugged.

 

As a last resort if none of the above solves your issue

1-) Completely re-install ETS 2, once re-installed open and choose Direct X 64 bit, then go into game and play a short job or something
2-) Exit and re-install TruckersMP again (as admin)
3-) Open TruckersMP (as an admin)
4-) See if the issue is resolved.

 

Also read these topics:

 

Link to post
Share on other sites
  • 0

Dear @Mr-Squirrel

 

Your topic has been inactive for 3 days since the last reply due to this i will have to move this topic to appropriate section

If you still need further help of this problem,feel free to DM me or other support team members,we  will open this again

 

Thanks for all participation!

Thank you for your understanding!

 

//Locked and Moved to Inactive

  • Like 1
Link to post
Share on other sites
  • 0

Hi  all

 

This topic has been inactive for a  further 2  days due to this i will have to move this topic to Unsolved Topics

Don't hesitate to contact us again if you need any further help in the future!

 

//Locked and Moved to unsolved

 

  • Like 1
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...