Jump to content

Question

Hello.I have an in-game problem.Idk but the game freezes when I enter or approach a zone with 5+ players.Also they render very close to me even tho they are set to render at 500m...tags says it all about this.I don't lag in general,40 fps in average and even in Duisburg and Calais I have 20 fps on Ultra.Halp ok thank.

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 1

Hello,

 

First of all, do not forget that FPS falls in crowded areas.
 

Please try the solution steps:

 

  • Update your graphic card driver.
  • Reinstall the mod and make sure that you put correct in directory. (\Steam\SteamApps\common\Euro Truck Simulator 2)
  • Make sure you have the latest .Net Framework (4.7) & DirectX & Microsoft Visual C++ 2015 and use CCleaner to remove temporary files and obsolete registry paths.

 

Finally, please follow this steps:

 

You should start TruckersMP as admin. This is really important. -Also try to start TruckersMP with DirectX (64).

 

 

  • Open your Steam.
  • Go to library.
  • Go to Euro Truck Simulator 2.
  • Click "Play". 
  • Choose "Launch with DirectX (64-bit). Make sure you chose 64 bit..
  • Start Euro Truck Simulator 2.
  • Choose your profile and press "drive".
  • Close Euro Truck Simulator 2.
  • Start TruckersMP as admin. TruckersMP will start with DirectX for all time. Except you change it again.
  • Also try to reinstall TruckersMP.
  • Go to '%programdata%' and delete the folder 'TruckersMP'. After that uninstall TruckersMP and download the MOD again: https://truckersmp.com/download > Launch the installer as admin.

 

Best regards.

 

Share this post


Link to post
Share on other sites
  • 2

Hello,

 

Common solution is to fire/dismiss all your drivers and then remove/sell their trucks. Sometimes MP takes a while to sync all of the drivers and their trucks so it ends up freezing. Once you do this, the freezing times should reduce or completely stop.

 

Alternatively if the above fails to work:

 

  • Go to Steam Library
  • Right click Euro Truck Simulator 2
  • Properties
  • Local Files
  • Verify Integrity of game files
  • Wait for the process to complete then relaunch ETS2 in DirectX mode.

Good luck with! Best regards.

Share this post


Link to post
Share on other sites
  • 2
Guest BombZ

@Stefan86239 Hello!

  • Update your video card driver
  • Remove MP again Install
  • Delete your profile open a new one

And review the following topic : 

Regards B)

BombZ

Share this post


Link to post
Share on other sites
  • 1
Guest ^^Mr.Wolf^^ ~[CZ/ENG]

Hello dear @Stefan86239

Please follow my steps : 

 

 

1.Step 

- Go to steam library

- Right click on ETS 2 

- Properties

- Local Files 

- Verify  in -game files   ---- https://imgur.com/a/1kDaNQL

 

After this step you can restart your pc and then you start the game with DirectX,please you play in - singleplayer few minutes   ----- 

https://imgur.com/a/iXEQp3a

 

2.Step 

-  Go to This Computer

- Local Disc

- Program Files(x86) 

-  Steam (folder)

- steamapps

- common 

- Euro Truck Simulator 2 - bin - and you can remove this folder -- win_x64 -- win_x86  -- / ----- There are this folders : https://imgur.com/a/pVXJD7Q

 

When you will be start the steam , and you will be play the game , so it will be say you , that some files are not in - game (win_x64/win_x86) -- So you will be have a little update in steam :) Dont worry 

 

When you will be still have a same problem you can try re-install the launcher : 

Steps for re-install : 

1.Please you press this keys : Windows + R and write %programdata% in to the line ----- https://imgur.com/a/2cVTT96

2.As next step , you find folder , which is called TruckersMP

3.Open it , and then you will see in folder , file which is called uninstall , so you click on it , and you do it.  // Also you can uninstall in Control Panels -- Programs --- https://imgur.com/a/5FR5eOn

4.Then you can check if you have not none folder from TMP in your Computer  // Go to Documents and folders / ETS 2 MP and ATS  MP please removed.

5.After this steps you are ready for download mod again :) 

6.Link for currently the launcher :  -> https://truckersmp.com/download

 

 

Good Luck and Happy Trucking  ! 

Best Regards 

Mr.Wolf_**CZ** =) 

TMP Members 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
  • 1
Guest ^^Mr.Wolf^^ ~[CZ/ENG]

Maybe you should try also the things in the topic : 

 

Also you can try  in- game to open your Tab list -> Settings -> General -> Development Logging = Disable it ! 

After you did that just click on Apply and ok -> Restart your Game

 

Is possible , that you will be a problem with GPU :) , so check this topic later : 

 

 

I hope , that it helps you 

Kind Regards 

Mr.Wolf_**CZ** =) 

TruckersMP Members

 

Share this post


Link to post
Share on other sites
  • 0

Hey

 

As you say you get 40 as normal and 20 at Calais and Duisburg, I guess the problem is that you need to change your PC or buy new components to be honest.

 

Anyways try to upgrade your graphic car drivers and also if you can try to reinstall you operative system.

 

Also it would be helpful if you say the specs of your computer.

Share this post


Link to post
Share on other sites
  • 0

So,there is no way I am deleting my profile and start a new one.PERIOD.Also upgrading my pc is irrelevant,my friend has a better pc than me and gets about the same fps.And I also don't think those are low fps by any means,especially here with directx9 when my gpu is directx12.I tried firing my drivers and launching ets2 in 64 bit directx but nothing works.I saw removing autosave or extend the period when it autosaves might be a fix.I will come with updates.Cheers.

Specs(copy pasta from steam ik its written different):

MOBO:Gigabyte GA H81M-S
CPU:Intel Core i5-4690 3.5 GHz 6MB 1150
RAM:1xPatriot 4GB DDR3 1600MHz CL11
GPU:Gigabyte GeForce GTX 1050 OC 2GB GDDR5 128-bit
PSU:Inter-Tech SL-500K 500W
HDD:WD Blue 1TB 7200rpm 64MB
SSD:Kingston HyperX Fury 120GB

Share this post


Link to post
Share on other sites
  • 0

YES!!!1!Reinstalling TruckersMP and unchecking those options you guys mentioned made my game run smooth again!Thank you so much!

Just to make it clear,I have:

  • disabled autosave
  • made ETS2 launch only in 64bit DirectX9 mode(choose 64bit only if your OS is 64bit)
  • reinstalled TruckersMP
  • unchecked every option that dropped FPS

I didn't include updating GPU drivers as Nvidia GeForce Experience always notifies me when there are new drivers and I download them right away.Thanks again guys!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...