Jump to content
  • 0
Feayture

Launcher doesnt ''launch''

Question

Recently i wanted to start playing again after a year. I did everything correctly choosing the direction etc etc however whenever i click on launcher it just dont show or do anything. No reaction at all and without seeing any error i have no clue how to solve this problem. I've been trying to fix this like a month now, tried almost everything but still didnt manage to find the solution. Help me about this please.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Hi friend, first try uninstalling TMP, after that download a version on the site and try to install again.


I also suggest that you do the following:

Press the Windows Key + R (Win+R) on your keyboard

Enter "%programdata%" and press Enter (without the quotes)

Find the folder "TruckersMP" and delete that folder.

Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"

Go to our website and re-download and install the Launcher with admin privileges https://truckersmp.com/download/

Open The Launcher with admin privileges and click "Install Available Updates"

 

 

You can find a little more info here:

 

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

Would you mind sending a screenshot showing the problem? Also try running TruckersMP as an administrator.

 

-right click  on TruckersMP

-click run as administrator 

 

You may also try troubleshooting it may fix the problem.

 

-right click  on TruckersMP

-click Troubleshoot 

 

 

Kimd regards,

-Arctic Wolf l Viva Trucking 

Share this post


Link to post
Share on other sites
  • 0

Firstly hello, try this:

  • If you are using Win 7 make sure you have Service Pack installed.

  • Try to run the TruckersMP as administrator.

  • If you are using any mods turn them off

  • Make sure you put correct path when you install the TruckersMP - default path is: C:\Program Files (x86)\Steam\steamapps\common\Euro Truck Simulator 2\

  • Turn off antivirus 

  • Turn off firewall

 

Best regards,

Good luck with

Share this post


Link to post
Share on other sites
  • 0

Dear @Feayture,

 

Multiple answers have been given. We'd like to get a feedback if the problem has been solved now or if you still need further help! :)

 

Kind regards,

MHT

Share this post


Link to post
Share on other sites
  • 0

Hello :) 

Follow these guides:

Solution 1:

  • Download Ultrasurf.
  • Run Ultrasurf.
  • Open TruckersMP in Administrator Mode.
  • Install the available updates (only the first run with Ultrasurf), wait for it to finish and Launch button appears.
  • Exit Ultrasurf

Solution 2:

  • In order to verify your game cache, go to your 'Library' and find 'Euro Truck Simulator 2'.
  • Once you find it, 'Right Click' and go to the 'Properties ' tab.
  • This will open up the properties tab. Go to the third sub-tab that says 'Local Files' where you will be presented with the following options.
  • Click on the last option to begin the validation process. This might take a few minutes.
  • Once all the files are validated, if any corrupt instances are found, then Steam will redownload those particular files for you. If not you will be greeted with a box that says no errors.
  • You have verified your game cache successfully.

Solution 3:

1. Click Start -> Run (or WIN+R)

2. Type regedit and hit enter

3. Follow the path HKEY_LOCAL_MACHINE\SOFTWARE\TruckersMP

4. Look at the value parameter "InstallLocationETS2"

 

If they differ:

1. Copy the folder address from STEP 1

2. Change the value parameter "InstallLocationETS2" (Insert the copied folder address)

3. Click OK.

After that, many users get another error: "Connection error - retry?" In this case, open Task Manager, close all Programmes of TruckersMP/ETS and try to start the Launcher as an administrator again.

Share this post


Link to post
Share on other sites
  • 0

thanks for the answers but still it doesnt work i did everything one by one but nope. I just dont get it it doesnt do anything when i doubleclick on truckersMP app.

Share this post


Link to post
Share on other sites
  • 0

This topic has been inactive for over 5 days and thus the topic will be moved to Unsolved topics.

If you still need help, feel free to submit a support ticket here: https://support.truckersmp.com

I hope that you're having a great day! :)

 

Kind regards,

MHT
 

//Moved to Unsolved

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×