Jump to content
  • 0

Speed Limiter?



6 answers to this question

Recommended Posts

  • 0



Make sure you save your settings, and follow the steps below.

This may be more than one cause, please check the steps;


  • First of all, do not get the job called "External Contract", which limits your speed to 90 km / h.
  • Remove "Speed Limiter" from the TAB Menu.
  • The EU 1 Server limits your speed to 90 km / h.
  • Also, remove the Speed Limit from the game files.

Just open C:\Documents\Euro Truck Simulator 2\profiles\ and navigate into the folder of your current profile. Open 'config.cfg' with a Text Editor, search for the line "uset g_use_speed_limiter" and make sure to put a "0" next to it. Then save and close the config-file and check if your speed limiter keeps disabled now


Best regards.


Former TruckersMP Game Moderator

Support of the Year 2018


Official Rules Official Turkish Rules | Support Ticket | Steam How to become a Game Moderator?




Nothing last forever.



Link to comment
Share on other sites

  • 0

Dear @itstemple,


You've got multiple answers. We'd like to know if your problem has been solved now or if you still have the problem!

Kind regards,


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.