Jump to content


7 answers to this question

Recommended Posts

  • 0

Hello Jack, Good night! :P

Try following the following steps, when finished doing what I quoted, see if it worked and say here in the comments! :v 


First Step:

I recommend you check the integrity of the files (ETS2) in steam, to do the "verification" just follow the steps below:


1. Enter your steam profile;



2. Click on: Library > Euro Truck Simulator 2 > Right click and go to properties;



3. Go to the "Local Files" tab and click on the button: Verify integrity of game files;




Steam will check all the files in your game to see if you have any corrupted files, if you have a corrupted file the steam will download the corrupted files again, otherwise it will say everything is normal.


Second Step:


1. Delete all TruckersMP files found on the Local Disk (C:) and in Documents
2. Download the TruckersMP Launcher again at: https://truckersmp.com/download
3. Install TruckersMP Launcher
4. If you were able to finish the installation, open Euro Truck Simulator 2, play a little and analyze if it will give some error, otherwise your error will be "solved"


NOTE: If your issue is not resolved through my response and response from other users, please contact TruckersMP Support, open a ticket at their help center: https://support.truckersmp.com/


Share this post

Link to post
Share on other sites
  • 0

Hello @Jake Peralta Transportes. Please read and try this solution.


1- To run the Windows scan and repair tool: Type "cmd" in the Start Search box.
2- Click "Request Command" in the results.
3- Enter the "sfc / scannow" command in the black window that opens and press the ENTER key.
4- Your system will be scanned for an estimated 20 minutes, if any problems are found and will be automatically corrected.
5- Restart the computer after scanning or editing.


If you can't find an answer to your problem, you can contact the support team. https://support.truckersmp.com/

Share this post

Link to post
Share on other sites
  • 0

Hi there

Try disabling your Antivirus utility and any other installed security utility then attempt the install again. 
If you have any open programs, close them.

  • Open Windows Defender Security Center 
  • Click Virus & threat protection 
  • Click Virus & threat protection settings 

Scroll down to Controlled folder access 
Toggle it off 

Also in Windows Defender Security Center 

Open App & browser control 
Set 'Check apps & files' to off 

Still not working? 

Open Start 
Type: cmd 
Right click CMD 
Click Run as administrator 

At the command prompt, type: 
net user administrator/active:yes 

Hit Enter 

Then close command prompt, to close the Administrator: Command prompt window, type Exit, and then press Enter. 

After that restart your PC


Then download TMP Launcher and install it again: https://truckersmp.com/download

Share this post

Link to post
Share on other sites
This topic is now closed to further replies.

  • Create New...