• Announcements

    • LIGHTOFGOD

      Active Recruitments   02/24/18

      Game Moderator Recruitment - 11th of August to 30th of September 2018   Find out more information, here:      
    • Prime

      Current Hot topic: ETS and ATS 1.32   08/12/18

      What do you think the impanct of 1.32 will be on TruckersMP and how the mod will be played,...   Discuss it all with us in this Hot topic:  
Sign in to follow this  
WooQash

OBS - ciągłe lagowanie obrazu

Recommended Posts

Cześć.
 

Postanowiłem w końcu poprosić o poradę, bo mam powoli dość. Mianowicie chodzi o OBS'a i notoryczne lagowanie obrazu. Dźwięk jest ok.
 

Tutaj macie próbkę: https://youtu.be/cma4Iqo3nc4?t=17m50s (17:50 - 18:35)
 

Już tłumaczę dokładnie o co chodzi. Gra chodzi w płynnych 30 FPS'ach i nie laguje tak jak na materiale nawet w minimalnym stopniu. Obraz laguje tylko i wyłącznie w materiale z OBS i nie ważne czy streamuję, nagrywam na dysk czy zapisuję bufor replayu.
 

W takim przypadku jak od 17:50 do 18:35 gdzie lagi są mocne dostaję komunikat, że "Enkodowanie przeciążone...". Moje normalne ustawienia to kodek sprzętowy NVENC z bitratem 2500.
 

X93Zj.png

 

Od momentu 18:35 kiedy mówię o krótkim zw, przerwałem materiał i zmieniłem kodek na sprzętowy QSV z identycznymi parametrami. Co prawda od tamtego momentu potężne lagi zniknęły (komunikat o przeciążonym enkoderze nie występował), ale cały czas widać takie mikrolagi (które występują równo na jednym jak i drugim kodeku, kodeku programowego nie biorę zbytnio pod uwagę z wiadomych względów).

 

Specyfikacja sprzętu:

Laptop Lenovo Y510P (2014)
- Płyta główna: Lenovo YIQY0Y1
- Procesor: Intel Core i7 4700MQ @ 2,40GHz
- Grafika: Intel HD Graphic 4600 (zintegrowana)
- Grafika: nVidia GeForce GT 755M (2GB)
- RAM: 2x4GB DDR3 PC3-12800
- Dysk: SSHD Seagate ST1000LM014 1TB
- System: Microsoft Windows 10 Pro

Internet: 50Mbit/s (download) / 5Mbit/s (upload)

 

Próbowałem bawić się z bitratem, ustawieniem enkodera, priorytetem procesu ale nic to nie daje. Cały czas są te mikrolagi, a czasami właśnie wyświetli się, że enkoder przeciążony kiedy nawet żadnych opcji nie ruszałem.

Czy ktoś ma jakiś pomysł co jeszcze można by przestawić aby udało się ogarnąć sytuację i zniwelować te mikrolagi?

Share this post


Link to post
Share on other sites

Co prawda na laptoptach bardzo się nie znam, ale

 

Wydaje mi się że to jest wina tylko i wyłącznie sprzętu. Jak próbowałem streamowac / nagrywać swoim prockiem ( Pentium G3258 ), miałem podobnie jak Ty. Niby gra nie lagowała, ale stream / nagranie już tak. Po ustawieniu karty graficznej jako enkoder ( GTX 750 Ti) tylko raz na jakiś czas, bardzo sporadycznie zdarzył się jakiś mikro-lag. Specyfikacja twojego laptopa optymistycznie nie wygląda, jęsli chodzi o streaming.

 

Pozdrawiam

Share this post


Link to post
Share on other sites

@Kid Fabi zdaję sobie sprawę z tego, że to laptop i nie ma w nim mega bebchów, ale wystarczy spojrzeć na wcześniejsze materiały, które nagrywałem/streamowałem i nie ma tam takich problemów.

 

Pierwszy z brzegu film z jakiegoś reporta ze stycznia. Tutaj jest dość płynnie, a tak na prawdę na przełomie tych 3 miesięcy nie zmieniałem diametralnie żadnych ustawień po za aktualizacją systemu i sterowników.
 

 

Share this post


Link to post
Share on other sites

Ustaw priorytet OBS w Windowsie na "powyżej normalnego" - Lagi się usuną na obrazie streama, aczkolwiek Ty je będziesz odczuwał. 

  • Thanks 1

Share this post


Link to post
Share on other sites

Witaj. Miałem ten sam problem z OBSem na Nvidii GTX 970. Przy nagrywaniu za pomocą Shadowplay nie miałem, żadnych problemów. Rozwiązałem to przełączająć na Quick Sync.

Tu masz screeny ustawień. 

Przechwytywanie.PNG

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this