• Announcements

    • LIGHTOFGOD

      Active Recruitments   02/25/18

      Community Moderator Recruitment - 23rd of May to 15th of July 2018   Find out more information, here:     Support Team Recruitment - 14th of July to 14th of August 2018   Find out more information, here:     Add-On Team Recruitment - 14th of July to 14th of August 2018   Find out more information, here:      
  • 0
Sign in to follow this  
g59nick

Black screen when launching

Question

I use to launch it off truckersMP and it would almost immediately show the euro truck simulator screen spinning and all the crap that pops up before menu. Now it takes 45 sec to a 1 minute to show that euro truck simulator screen then login menu, any advice?

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Hello @g59nick You can try few solutions for your problem:

  • First of all, just try to verify your game cache. If you don't know how to do:
    Open Steam, click Libary and find ETS 2 then right click on ETS 2, select Properties.
    When window shows up, click to Local Files and select Verify Integrity of Game Files.
    Wait for update and try it again.
  • You can try to upgrade your graphic cards driver. If you're Nvidia user, just check it from Nvidia Geforce Experience. If you're AMD user, use AMD drivers website.
  • Also, open ETS 2 Singleplayer via 64 bit Direct X mode.
I hope it works, good luck! ^_^

Share this post


Link to post
Share on other sites
  • 0

Hello,

 

I have put a few steps down below and I do hope it helps you out!

 

  1. Try to launch the game in single player, once that has been completed lower your graphics settings, this may speed up the process.
  2. Try launching with administrative privileges.
  3. Go to your task manager (CTRL+ALT+Delete, then select task manager)
    1. Right click on the game > Details
    2. Right click again > Set Priority > Above Normal or High

 

If this does help you out please let us know :)

Regards.

 

 

Share this post


Link to post
Share on other sites
  • 0
Please Follow this step's:
1-) Go to Documents and Delete the ETS2MP Folder
2-) Press the Windows Key + R (Win+R) on your keyboard
3-) Enter "%programdata%" and press Enter (Without the quotes)
4-) Find the folder "TruckersMP" and delete that folder.
5-) Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher"
6-) And, go to re/download this launcher here: https://truckersmp.com/download

OR
Make sure you have the latest .Net Framework (4.7) & DirectX & Microsoft Visual C++ 2015
and use CCleaner to remove temporary files and obsolete registry paths.
 

Share this post


Link to post
Share on other sites
  • 0

Due to inactivity +5 days, we will move this to an unresolved issue
If you have a problem in the future, create a new topic or create a support request

 

/// Moved to unsolved topics

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this