Jump to content
  • 0
[GearUp] Timykingmy

FPS drop on auto-save

Question

Hi guys,

 

So normally i can play with 60 fps+, but now when it autosaves, I always have a lag spike. Pretty annoying in convoys :(

Does someone have a solution for this? Thanks

  • True Story 1

Share this post


Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 1

FPS drops during auto save because the game save all your profile data an a HDD and need to wait for the data was writen, before continue rendering scenes and processing gameplay.

If you play on notebook, most notebooks have a slow HDD, what cause a delay when information write to it.

If you have a not enough RAM memory, OS already bake up some data from memory to a HDD, also most windows processes can use HDD for their thing, you can have game installed on separate phisical HDD but ETS and ATS store profiles in a user documents folder what placed on a primary partition with windows. So the problem is a slow HDD or lack of RAM memory or both.

 

You can try:

Do a defragmentation for all your HDD, that can increase disk speed.

In game, have less garages, fire all your drivers, sell not used trucks by yourself (That result in less data neede to be saved during autosave). If you use TEdit, stop using it and return setting in game configuration file about save format to it's defaults what make game use custom save format, what can be more speedy, instead of plaintext.

Share this post


Link to post
Share on other sites
  • 0

Other than turning down your video settings in-game, you could try doing a RAM cache cleanout before running the game.
You could also try using a game accelerator, like Razer Cortex (which comes with recording software as well).
Also make sure your graphics card drivers are up-to-date.
I'm sure there are other suggestions that might help, but that's all I can think of for now.

EDIT: Just thought of something else. Turn off all weather effects.

Edited by RickyWong

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, RickyWong said:

Other than turning down your video settings in-game, you could try doing a RAM cache cleanout before running the game.
You could also try using a game accelerator, like Razer Cortex (which comes with recording software as well).
Also make sure your graphics card drivers are up-to-date.
I'm sure there are other suggestions that might help, but that's all I can think of for now.

EDIT: Just thought of something else. Turn off all weather effects.

Thanks, Will try this!

Share this post


Link to post
Share on other sites
  • 0
17 minutes ago, RayRay5 said:

The bigger your savegame, the longer the freeze. You can reduce the "lag spike" by firing your drivers and selling some trucks.

 

I'll also try this! Thanks!

Share this post


Link to post
Share on other sites
  • 0
56 minutes ago, Tavren said:

FPS drops during auto save because the game save all your profile data an a HDD and need to wait for the data was writen, before continue rendering scenes and processing gameplay.

If you play on notebook, most notebooks have a slow HDD, what cause a delay when information write to it.

If you have a not enough RAM memory, OS already bake up some data from memory to a HDD, also most windows processes can use HDD for their thing, you can have game installed on separate phisical HDD but ETS and ATS store profiles in a user documents folder what placed on a primary partition with windows. So the problem is a slow HDD or lack of RAM memory or both.

 

You can try:

Do a defragmentation for all your HDD, that can increase disk speed.

In game, have less garages, fire all your drivers, sell not used trucks by yourself (That result in less data neede to be saved during autosave). If you use TEdit, stop using it and return setting in game configuration file about save format to it's defaults what make game use custom save format, what can be more speedy, instead of plaintext.

 

Thanks for your reply! I always do a defragmentation, but maybe my HDD isn't that good anymore. I have a SSD and a HDD. Is there maybe a way to switch the documents/Ets2 folder to my ssd (if you know)?

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, timykingmy said:

 

Thanks for your reply! I always do a defragmentation, but maybe my HDD isn't that good anymore. I have a SSD and a HDD. Is there maybe a way to switch the documents/Ets2 folder to my ssd (if you know)?

Sadly, but no... i think the only one way to do that it's modify somewhere values in registry, but not sure and that can make other application stop working if they use default document folder location, more simply in that way it's move a system to a SSD.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
11 minutes ago, Tavren said:

Sadly, but no... i think the only one way to do that it's modify somewhere values in registry, but not sure and that can make other application stop working if they use default document folder location, more simply in that way it's move a system to a SSD.

Alright, thanks anyways!

Share this post


Link to post
Share on other sites
  • 0
46 minutes ago, RayRay5 said:

The bigger your savegame, the longer the freeze. You can reduce the "lag spike" by firing your drivers and selling some trucks.

I tried this, and sadly, it didn't work.. :( I'll try the other solutions, thanks anyways!

Share this post


Link to post
Share on other sites
  • 0

Go to C:\Users\xxx\Documents\Euro Truck Simulator 2 .

Then open config.cfg with Notepad or Notepad++.

Go to Line 107 "uset g_save_format  and make sure you have at the end of the line "0" instead "1" or "2" etc.

 

I had the same problem and this method worked for me

 

Kind Regards,

Fabian
 

  • True Story 1

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, izm07 said:

Hey! @timykingmy Close background programs while playing ets2mp because when you trying to save game, hdd usage incrases %100 for a sec. That's the reason why fps drop/freezing generally.. Also you can try to close Anti-Aliasing. Good luck! ^_^


Cortex does this for you and is handy for those who aren't that "tech savvy".

Share this post


Link to post
Share on other sites
  • 0
18 hours ago, RickyWong said:


Cortex does this for you and is handy for those who aren't that "tech savvy".

 

Well I already tried this one and it didn't work, fps did go up a bit but that was not the problem :P 
 

20 hours ago, Kid Fabi said:

Go to C:\Users\xxx\Documents\Euro Truck Simulator 2 .

Then open config.cfg with Notepad or Notepad++.

Go to Line 107 "uset g_save_format  and make sure you have at the end of the line "0" instead "1" or "2" etc.

 

I had the same problem and this method worked for me

 

Kind Regards,

Fabian
 


Thanks for your reply! Will try this! Thanks!

Share this post


Link to post
Share on other sites
  • 0

Hi timykingmy,

 

do you already checked into your Tab list -> Settings -> Development Logging is it enabled or disabled?

Because of this one you can get some little Lags too, because just was trying it and disabled it so you

reduce some little Lags.

 

But the another thing what can be the reason too is, do you already tried it with a new Profile?

Because if you just try a new Profile and you don´t have this auto save - lags then you can be sure

your Profile is a little bit broken. Some Friends from me had the same Problem and we tried to some

Save Game from me and it was working without any Problems anymore.

 

Hope it was a little answer for you.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
20 hours ago, [TUG] Harley said:

Hi timykingmy,

 

do you already checked into your Tab list -> Settings -> Development Logging is it enabled or disabled?

Because of this one you can get some little Lags too, because just was trying it and disabled it so you

reduce some little Lags.

 

But the another thing what can be the reason too is, do you already tried it with a new Profile?

Because if you just try a new Profile and you don´t have this auto save - lags then you can be sure

your Profile is a little bit broken. Some Friends from me had the same Problem and we tried to some

Save Game from me and it was working without any Problems anymore.

 

Hope it was a little answer for you.

 

Thanks for your reply! I'll try this!

Share this post


Link to post
Share on other sites
  • 0
On 12/21/2017 at 6:23 PM, timykingmy said:

 

Well I already tried this one and it didn't work, fps did go up a bit but that was not the problem :P 
 


I'm sorry this didn't solve the freezing issue for you, but I am glad to hear that it did indeed improve your overall game performance. 
I've personally never had much of an issue with freezes such as this in this game. It has never frozen for more that the splittiest of split seconds (Is that a real term? Meh. It is now. lol).
Kid Fabi's suggestion looks very promising. Though, it kind of seems of a bit of a "sledgehammer for a nail" type of approach, but it should well and truly fix your problem.

 

On 12/22/2017 at 12:34 AM, [TUG] Harley said:

do you already checked into your Tab list -> Settings -> Development Logging is it enabled or disabled?

Because of this one you can get some little Lags too, because just was trying it and disabled it so you

reduce some little Lags.


I'd try Harley's suggestion first. Just mho.

  • Haha 1

Share this post


Link to post
Share on other sites
  • 0
19 hours ago, -XCE- said:

@timykingmy

 

Has your problem been solved?

Please let us know as soon as possible.

 

Best Regards,

TruckersMP Support

-XCE-

 

No sadly it isn't but i think i have to live with it.. :( I think I just need to upgrade my ram and videocard. But everyone thanks for all replies <3 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...