• Announcements

    • Chris - TFM

      Game versions updated - It's time to downgrade!   08/16/17

      Once again a new version of Euro Truck Simulator 2 and American Truck Simulator have been released. If you wish to carry on playing TruckersMP, for the time being you will need to downgrade your game versions to   ETS2: "temporary_1_27 - 1.27.x for incompatible mods" ATS: "temporary_1_6 - 1.6.x for incompatible mods"   Use the following to learn how to downgrade:      Thanks!
  • 0
Aiko

Unsupported game version! Help me!

Question

Normally it's easy to fix it, but this time, I have a problem with it.

image.png.f44617ccd01bf90232bd3dab436336f1.png

So, I check Steam, but I can't find the good one.

image.png.40d4891a651140470d31244d748dff46.png

Someone who can help me?

 

Thanks! 

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 4

You must set valid ETS 2 version ! 

  • Open Steam
  • Library
  • Euro Truck Simulator 2 / properties
  • Betas 
  • Set " NONE-opt out of all beta programs"



Enjoy

Edited by Lukavsky

Share this post


Link to post
Share on other sites
  • 0

I know this may sound stupid, but have you tried rebooting your computer? Then check to see if you have opted in to betas, and if so opt out. If this doesn't work, backup the profiles folder in the Euro Truck Simulator 2 folder in documents. i.e. C:\Users\"User Name"\Documents\Euro Truck Simulator 2\profiles. Then go into Steam, right-click on ETS2, select properties, local files, then select verify integrity of game files. This may take a while. If this doesn't work, and this is where the profiles save comes in handy, uninstall the game. Reinstall it, then launch SP, and when it is launched, close back out. Don't make a new profile, just back out. Then go back into the ETS2 folder in documents and copy over the profiles folder and relaunch the game. If this doesn't work then I don't know what will.

Share this post


Link to post
Share on other sites
  • 0

I tried the 1.28 open beta and wanted to enter the truckersmp then it warn me 'this version is 1.28 bla bla. So i set NONE-opt out of all beta programs and i tried to connect again and the game still  says unsupported game version and i cant play ets2 online and offline . Is my save broken or something? How can i play again pls help me

Share this post


Link to post
Share on other sites
  • 0
On 06.08.2017 at 2:47 AM, Yoyo_ManSg said:

Hello @Tnc3,

 

To try to resolve your problem, I advise you to read this guide:

Cordially,

Yoyo_ManSg

 

 

 

Thanks for reply but i tried this way and it didnt worked. It still exist same problem. I removed the 1.28 beta and this time the game says unsupported game version again...7710incij3117237.png

Share this post


Link to post
Share on other sites
  • 0
18 minutes ago, Tnc3 said:

 

 

 

Thanks for reply but i tried this way and it didnt worked. It still exist same problem. I removed the 1.28 beta and this time the game says unsupported game version again...7710incij3117237.png

You must follow my steps 

Steam/Library/Euro Truck Simulator 2/properties/Betas and set "NONE-opt out of all beta programs"

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, Lukavsky said:

You must follow my steps 

Steam/Library/Euro Truck Simulator 2/properties/Betas and set "NONE-opt out of all beta programs"

yes , i tried it but when i set like this , the game opens and cant load the saves

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Tnc3 said:

yes , i tried it but when i set like this , the game opens and cant load the saves

You must wait , first game must be installed :)

Edited by Lukavsky

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Lukavsky said:

You must wait , first game must be installed :)

 

Uhm no , i see my auto saves but i cant choose any of them because 'please update the game' writing all over my saves. I played 1.28 beta and my saves exists1.28 content so i cant open them in 1.27 update. I know its not about  truckersmp but i need yours help as someone who knows

Share this post


Link to post
Share on other sites
  • 0

You need to scroll down and find your older saves because 1.28 saves are not compatible with 1.27. You should aware that kind of problems when you switch between beta versions.

Share this post


Link to post
Share on other sites
  • 0

I would suggest reloading the save on which you were on the correct version, before you tried the beta.

The beta versions can cause your profile to be not backwards compatible, so try going back to one of your old saves.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.