Jump to content
  • 0
Sign in to follow this  
Vegasas

MP launches as SP

Question

Hi, i got problem. When i launch Play Euro Truck Simulator 2 Multiplayer, it launches as single player. I dont know what to do..

 

What i tried.. 

 

Launch as admin rights, steam and ETS MP

Set right version

Yes, im clicking on the right icon

 

7f04155817740a412696af2c364a5b63600.png

 

edb5860b9b5d9906b526b49caea91ee2751.png

 

help please? 

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Have you tried lunching the multiplayer from the ETS 2 MP folder?

 

just checked, didnt helped. 

Share this post


Link to post
Share on other sites
  • 0

So what folder did you chose the you installed the multiplayer. Program Files (x86) > Steam > SteamApps > Common > Euro Truck Simulator 2 

Share this post


Link to post
Share on other sites
  • 0

So what folder did you chose the you installed the multiplayer. Program Files (x86) > Steam > SteamApps > Common > Euro Truck Simulator 2 

 

edb5860b9b5d9906b526b49caea91ee2751.png

 

install directions..

Share this post


Link to post
Share on other sites
  • 0

what you mean, take a look on the link and its stand whats maybe can help you out. 

 

NOTE: If you are having a normal pc user it won't work lunching the mod, you need to use the administrator user. 

Share this post


Link to post
Share on other sites
  • 0

what you mean, take a look on the link and its stand whats maybe can help you out. 

 

NOTE: If you are having a normal pc user it won't work lunching the mod, you need to use the administrator user. 

 

Link didnt help.. 

 

Im already admin on pc? cd382380086a0dad99ecf09b1dced5d9448.png

Share this post


Link to post
Share on other sites
  • 0

you see a shortcut on the desktop a icon of multiplayer click with right mouse on that icon and start the game with administrator rights

 

you can also click on that icon select properties and go to tab compatibility and then you see under run the game always with administrator rights that one you must select  

Share this post


Link to post
Share on other sites
  • 0

you see a shortcut on the desktop a icon of multiplayer click with right mouse on that icon and start the game with administrator rights

 

you can also click on that icon select properties and go to tab compatibility and then you see under run the game always with administrator rights that one you must select  

 

Still nothing.. :(

Share this post


Link to post
Share on other sites
  • 0

Hi, i got problem. When i launch Play Euro Truck Simulator 2 Multiplayer, it launches as single player. I dont know what to do..

 

What i tried.. 

 

Launch as admin rights, steam and ETS MP

Set right version

Yes, im clicking on the right icon

 

7f04155817740a412696af2c364a5b63600.png

 

edb5860b9b5d9906b526b49caea91ee2751.png

 

help please? 

 

Looks like you are on beta. I suggest you opt out of all betas on properties in steam.

Share this post


Link to post
Share on other sites
  • 0

I had the same problem. I just fixed it by running the ETS2MP shortcut as admin.

 

i did, its not working

 

 

Looks like you are on beta. I suggest you opt out of all betas on properties in steam.

 

So i need to make my beta to opt out of all beta programs ?

Share this post


Link to post
Share on other sites
  • 0

Yes. No betas should be active because the latest ETS 2 MP client relies on ver. 1.15.1.1s to work.

 

still nothing.. 

Share this post


Link to post
Share on other sites
  • 0

Now that you have opted out of all betas on steam, Un-install the ETS 2 multiplayer client. Restart your PC, and re-install ETS2 MP.

 

still the same problem...

Share this post


Link to post
Share on other sites
  • 0

As a last resort you could do a fresh install of ETS 2 on steam and the multiplayer client (re-download them), as long as you have the bandwith available. Otherwise i have nothing more to offer. 

 

Good Luck.  :)

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

have you checked to make sure that ets2 is allowed through firewall?

 

how to check? Also tryied to turn off firewall and launch MP, but nothing..

Share this post


Link to post
Share on other sites
  • 0

Another option is to check if "shortcut" has "parameters" added. Right click on shortcut -> Properties, see if any parameters beside filename is there, like -64bit etc. It launches SP if you have them so.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...