Jump to content
lxl Semper lxl

In-Game FPS GPU CPU Usage ?

Recommended Posts

I am wondering if I have built in software already or is there something that can do this for me I did how ever try MSI Afterburner but my hardware isn't MSI and when I ran it and tried to run TMP it wont load the game at all but when I close MSI Afterburner it will load game

 

I don't trust the Steam FPS Overlay I think its giving me false reading of 24FPS on ATS constant at any setting I am just curious to see what I can use if you look at screenshot provided under device manager the graphics that's what I have

 

CPU_Info.png

Share this post


Link to post
Share on other sites

If you use MSI Afterburner and RivaTuner Statistics Server, make sure to update the RivaTuner Statistics Server to the latest beta version 7.0.0 Beta 19.

 

Also Nvidia has a nice build in FPS counter. 

  • Upvote 1

Share this post


Link to post
Share on other sites
Guest DFGssadWGEYGTWESGasadfdy

You need to go to geforce experience if you have Nvidia and press on the share tab.  It'll open a little box and you press on settings, and fps and you select the quadrant you want the fps counter in.  @lxl Semper lxl

Share this post


Link to post
Share on other sites

Open up Nvidia Geforce Experience > Click on Settings icon > Click on Nvidia Share settings option > HUD Layout > FPS Counter > Select a corner and thats it

 

As for MSI as @PrototypeGR told you to update RivaTuner server to 7.0.0 since the one MSI provides is 6.5.0 and 6.5.0 does not support Creators update and has outdated game hooks.

Uninstall Older RivaTuner Server and Install 7.0.0 from here http://www.guru3d.com/files-details/rtss-rivatuner-statistics-server-download.html

 

Reboot PC and you should be good to go. Just Remember to Select Start with Windows and Start Minimized in RTSS^ . Configure it the way you want and enjoy.

  • Upvote 1

Share this post


Link to post
Share on other sites

Ok here is my problem and thanks @MrHarv98 for directly showing me the FPS issue now my problem is you all know my rig and the picture above states that ive spent a huge amount of money on this I don't know what I am doing wrong but I thought even the I-core 7 7700k 4.2ghz would give me better than 24 fps on ATS as you can see with picture below I don't know whats happening !!!!! but even if I lower it to say medium I think it still gives me that aswell I will check after I complete this post.... am I doing something wrong do I need to alter graphics card settings or what to get better fps its just shocking the results I'm getting with the game that's all really putting me down honestly as I feel I have created in my eyes a kick ass gaming system that should handle anything at present...

 

20170421153015_1.jpg

 

 

EDITED:

Just look at that picture and changed one thing (Refresh Rate) changed that to 59MHZ and boom the issue is resolved and all fixed that's weird because I thought default would adjust itself for the system requirements obviously not !

Edited by lxl Semper lxl

Share this post


Link to post
Share on other sites

Hi, if you write the following commands in the console, you can see the FPS using the in-game counter, (not Steam.. this works for both ETS2 and ATS).

nPsOVF9.png

 

You then should be able to see the FPS in the top of the screen like this: 

VMfiqP3.png

 

If you need help turning on the console, refer to this (Should work for ATS as well) - http://forum.scssoft.com/viewtopic.php?f=11&t=61852

  • Upvote 3

Share this post


Link to post
Share on other sites

@MrHarv98 Yes just done it now but its not doing what I want it to do well it kinda is but it isn't lmao I'm complicated...... I  wanted like example

 

GPU Usage 13% <---- I think I got that one though

CPU Usage 30% <----- I think I got that too

Ram Usage 6496 something something cant take screen shot <<<--- is there a way for it to say the amount used and show what total the system has for example 5.8 gig % out of 16.0 gig used or something similar ?

 

there is a few things but when I take screenshots they done show the settings hmm ill try a GeForce screenshot :P ill edit post if it works lol

 

See the ram don't understand what its trying to say its using 4 gig out of 6 gig allocated to the game ? because I assure you there is 16 gig installed lol

 

American_Truck_Simulator_04.22.2017_-_16

 

I might just use CPU GPU RAM as I'm at overkill at moment.....

American_Truck_Simulator_04.22.2017_-_16

Edited by lxl Semper lxl

Share this post


Link to post
Share on other sites

 

Open MSI Afterburner > Settings > Monitoring 

 

Keep the options Ticked which you want to see/observe/monitor rest untick them. Mine is like this 

 

 


Screen%20recording%202017-04-23%20at%201
 

 

 

Then Click "Show in On-Screen Display" after selecting the group you want to monitor , Say CPU Temp and used , Click CPU Temp >Show in On Screen Display and Tick Override group name and Name it to CPU Temp.

Do this^ for every group/item you want to see in OSD/In-Game.

 

As for your Ram question. Max Limit is defined by default by the system, It will show how much used in MB not in %.

In game or In OSD it will show RAM: <MB Used> , <MB Available/amount of ram in system>

 

That's how i have my InGame Monitoring

 

 

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...