Jump to content
  • 0

Downgrade issues


ILoveIcedTea
 Share

Question

I'm trying to play MP with my friend, but something is stopping me from doing so.

Whenever I press "Launch ETS2" it gives me an error (occasionally two) and then crashes my launcher etc.

7438cd30a04d774624f9d3ed33c489c1.png

This is the first error

It says I need to downgrade, blah, even though i'm already on the version 1.26 (I get no other 1.26.3 options)

1a5fec66bb8005f00389640b6cc51523.png

I also get this error sometimes, still not entirely sure what this means.

Any help would be appreciated, it's rather annoying.

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hello @PessimisticBanana,

 

Is this the first time you're trying to play the mod after the auto patcher update? If so, remember to delete the old shortcut to ETS2MP and use the auto patcher shortcut. Also, use NONE - Opt out of all beta programs. That way you'll have the latest version of the game which is supported at the moment.

 

I hope this help you,

 

TruckBro

Edited by TruckBro

 

Ready to go!

 

Link to comment
Share on other sites

  • 0

Hello, 

 

So, I have had this issue sometimes when it comes to downloading the new version of TruckersMP. The way you can resolve this issue is by changing your beta settings to NONE- Opt out of all beta programs

 

You can do this by

1) Go to your steam library

2) Right click 'Euro Truck Simulator 2' 

3) Click on 'Properties' 

4) Once you're on properties press 'BETAS' 

5) Change 1.26 to NONE- Opt out of all beta programs

 

Hope this helps! happy trucking!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.