Jump to content
Sign in to follow this  
Kibatsume

How to Solve "Unsupported game version" problem.

Recommended Posts

Hello,

 

I hear most of you guys having the Unsupported game version error after installing the mod.

In the following guide, I will give you two ways to solve this error.

 

Solution 1 Upgrading / Downgrading you're game version.

 

Step 1 Check if you need to downgrade or no from public beta.

 

Can be done here (Works for ETS2 / ATS):

If you need to downgrade you're game, follow the steps on the tutorial linked ^ and try to launch the game again, in the correct version.

 

If this has been done yet and you still have the issue, you can go to solution 2.

 

 

Solution 2 Reinstalling the mod

 

Step 1 Download the mod from http://truckersmp.com/en_US/download and launch the install.

 

If you are having the issue on ATS

Spoiler

 

Step 2: When time to select your American Truck Simulator Directory

 

25f6210a4e3247e1ae2acb15a1d1e28a.png

 

Make sure that in the red box is written this adress. (Copy/Paste if needed)

C:\Program Files (x86)\Steam\steamapps\common\American Truck Simulator

Then "Next" and keep going with the installation.

 

Step 3: Run the game.

 

 

 

If you are having the issue on ETS2

Spoiler

 

Step 2: When time to select your Euro Truck Simulator 2 Directory

 

e3c321b53b58408ab594e10ed9b2611d.png

 

Make sure that in the red box is written this adress. (Copy/Paste if needed)

C:\Program Files (x86)\Steam\steamapps\common\Euro Truck Simulator 2

 

Then "Next" and keep going with the installation.

 

Step 3: Run the game.

 


 

 

I hope this could help you to solve the issue, If you still having problems after following the steps of this tutorial, feel free to PM me or to post you're issue in https://forum.truckersmp.com/index.php?/forum/55-help/

  • Like 1
  • Upvote 4

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...