• Announcements


      Forum Moderator Recruitment / Game Moderator Team Recruitment   03/02/18

        For Forum Moderator Team :      For Game Moderator Team:  Good Luck to everyone ! 
    • Prime

      Major Event requirements update   03/19/18

      In light of the recent changes to the requirements of event rules and servers the requirements for Major Event posts have also been updated.   A summary of the changes:  Added: Minimum 50 participants with proof at moment of creation Added: Topic created minimum 1 month in advance Added: In case of charity event: endorsement of non-profit organization or official donation link for the event by non-profit organization Removed: minimum post count   For the full list of requirements, check out the respective topics for ETS and ATS   Regards   TruckersMP team
    • Prime

      Issues hizliresim.com   03/20/18

      Since a few days we have noticed that pictures posted on hizliresim.com are not accessible (both on our forum and website). This is an issue not related to our services and out of our hands. Therefore we ask you not to use hizliresim.com to share images and opt for other alternatives such as https://prnt.sc/   We thank you for your understanding.    
    • Digital

      Easter Egg Hunt 25th March 16:00 UTC   03/23/18

      In case you missed it, you are invited to join us on a huge Easter Egg Hunt this Sunday 25th March 2018 at 16:00 UTC!   Check out the details here: https://forum.truckersmp.com/index.php?/topic/63166-easter-egg-hunt-25th-march-2018

Downgrading and Upgrading American Truck Simulator Version

Recommended Posts

Updated: 2018/01/11 (yyyy/mm/dd)


Downgrading and Upgrading American Truck Simulator Version



Whenever American Truck Simulator gets an update from SCS you need to downgrade the game version in order to use TruckersMP, because TruckersMP doesn't have support for the latest version right away. How soon TMP gets an update depends on how many changes there are in the new update. On average it takes less than 5 days. In this guide I will explain with text and GIF's how to downgrade ATS to supported version and how to upgrade it after TMP update.




Supported version:




Downgrading American Truck Simulator Version

(The latest version supported)*




 1. Open Steam, go to LIBRARY and GAMES.




 2. Click American Truck Simulator 





 3. Check first that are there any unsupported DLC mentioned below in the Unsupported DLC section of this guide. You need to uninstall the unsupported DLC before you can install the supported version. Uninstall the unsupported DLC by unticking them in the DLC list.



(Note: Nevada is not unsupported. The GIF is just an example of uninstalling DLC.)



 4. Right click on American Truck Simulator and open Properties





 5. When the Properties window is open click on BETAS tab




 6. In BETAS tab select [version will be added here when needed]


   [GIF will be added here when needed] 



 7. Now it should be downloading the version. You can now close the Properties window and wait for the download to finish.





 8. When the download has finished you're good to go. Happy trucking!




(Still experiencing problems? Go to help section and make a post describing the problems.)



The latest version supported: No need to downgrade to the previous ATS version.

Downgrade to supported version: The latest version of ATS is unsupported. Follow the guide to downgrade to supported version.

Status not available: Author of the guide is not able to keep the guide up-to-date for a longer period of time.





Upgrading American Truck Simulator Version




 Follow steps 1, 4 and 5 shown in downgrading guide above, but in BETAS tab select NONE - Opt out of all beta programs. Remember to reinstall any DLC you may have had to uninstall when you downgraded the game version.





(Still experiencing problems? Go to help section and make a post describing the problems.)





Unsupported DLC






Supported DLC


All the DLC excluding unsupported DLC mentioned above.






If you spot a mistake or out-dated information, please contact author with personal message or comment below.

Edited by DerAmpelmann
Changed supported version
  • Upvote 4

Share this post

Link to post
Share on other sites

The latest version of ATS ( is now supported in TruckersMP. Time to hit the road!

Edited by DerAmpelmann
corrected the version

Share this post

Link to post
Share on other sites

There's a new version out for ATS (1.29) along side the New Mexico DLC. Neither of those work in multiplayer yet.
See the downgrading guide, if you wish to play in TMP while the latest version isn't supported.

  • True Story 1

Share this post

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now