Jump to content
  • 0
Sign in to follow this  
UwotM8

Unsupported game version 1.14.2s

Question

3-4 month ago i had this issue that says, unsupported game version, yet i know a lot of people have this issue, but mine doesn't want to be fixed, so i decided to stop playing and wait until more updates come. So today i decided to download the MP again and guess what UNSUPPORTED F*IING VERSION!!! Says i need the 1.14.2s yet my game is set to 1.14.2s, i tried everything, i did the thing on steam that change the game version, never worked and now i'm here, asking help on the forum ;(

 

 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Try un-installing ETS2 and re-downloading, get back to me if that ain't a good solution  ^_^

I literally just did that! Nothing worked 

Share this post


Link to post
Share on other sites
  • 0

I found out what was the problem, 3-4 weeks ago my steam did a weird bug on me and deleted EVERYTHING single game i had on my HDD and SSD, but the folders stayed intact, so i moved my steam from my SSD to my HDD, but it created another file named EuroTruck Simulator, so when i was downloading and installing ETS2MP, it was installing the directory into the old folder i had on my SSD. Guess i was just an idiot but it's good to know it's fixed! Thanks for all the replies!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...