Jump to content
  • 0
PArmyHD

ETS2MP: Cannot validate game version(SOLUTION)

Question

For all those who are getting the error: Cannot Validate Game Version, Here is what you need to do.

 

1. Make sure that you have the latest version of ETS2MP.

 

1.B) If you do not have you correct version, go to http://ets2mp.com/index.php?page=downloadand download the latest version.

 

2. Log into Steam and go into your library.

 

3. Click on the 'ADD GAME' button in the lower-left of the screen.

 

4. Scroll down and find ETS2MP*. (It may be written differently to some people)

 

5. Wants its added, click on the ETS2MP on hit play.

 

6. Enjoy the game.

 

*If you cannot find the game when scrolling down, click browse and search 'Play Euro Truck Simulator 2 Multiplayer'.

 

I hope a lot more players can play ETS2MP now and that you do not have any more of these errors.

 

 

 

FOR ALL THOSE FORUM MODERATORS OUT THERE: I wasn't 100% sure where to post this so if it needs to be moved to a different location the please do so.

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

^This is adding non-steam game to Steam's library/  its not really a solution, because when the servers don't work...there's nobody to validate it for you

  • Upvote 2

Share this post


Link to post
Share on other sites
  • 0

Already tried this but that [can not validate game version] still happens every day.

Because I have a terribly bad connection maybe ?

Got used to this problem and it is not annoying anymore because I just think it's normal.

Share this post


Link to post
Share on other sites
  • 0

Its becuase the servers are down.. They seem to be down more then they are up at the moment, Pretty crappy when they got mod of the year 2014? There is no solution for this error its because the servers are down so don't worry nothing wrong with your computer/game just have to wait, and wait, and wait...

Share this post


Link to post
Share on other sites
  • 0

Its becuase the servers are down.. They seem to be down more then they are up at the moment, Pretty crappy when they got mod of the year 2014? There is no solution for this error its because the servers are down so don't worry nothing wrong with your computer/game just have to wait, and wait, and wait...

 

Over the past 3 days, yes... If you mean in general: No!

Share this post


Link to post
Share on other sites
  • 0

As far as I know cannot validate game version may be caused because of HTTP client which we use. There is need to sort it our one day by mwl and probably implement better approach such as libcurl or other 3rd party lib to be reliable in this segment.

  • Upvote 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...