Jump to content
  • 0

ETS2 Takes too long to start


JAMES JDM
 Share

Question

Hello.

 

So, I recently wanted to learn how to install a map mod, so I've tried one which was really big.

 

After a while, I started to see how the game was taking more time to start, I thought it might be because of the map mod. After a while trying to make it work, It was impossible, so I deleted all the mods files from the game, and cleaned everything. 

 

But there was a problem, I saw that the games was still slow when I tried to start it, (it takes about 30 to 40 seconds to start) so, I've tried to reinstall it, delete the mods, profiles, backup everything or even install it in another hard drive to check if that was the problem, but It hasn't changed. I don't know why the game keeps taking so long to start since I just inserted a map mod. 

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 1

Hi there! 

It is absolutely normal to take longer because the size of the mod is large. It happened to me with the map of Brazil. I waited about 20 minutes for it to load and get me into the game. Try to play from a different profile.

If it still doesn't work:
 

If the .net framework is lower than the version .Net Framework 4. Firslty, download the 4th version and then install the 4.6 version (if you have already 4. version or upper versions, download the 4.6 version directly). Also, try these:
 

Solution 1:
 

Reinstall TruckersMP Launcher:

1. Press the Windows Key + R on your keyboard;

2. Enter "%programdata%" and press Enter (without the quotes);

3. Find the folder "TruckersMP" and delete that folder;

4. Navigate to C:\Program Files\ and delete the folder named "TruckersMP Launcher";

5. Go to our website and re-download and install the Launcher with admin privileges (https://truckersmp.com/download/).

 

Solution 2:

 

You should start TruckersMP as admin. This is really important. Also, try to start TruckersMP with DirectX (64).

Guide:

1. Go to your Steam Launcher;
2. Go to the Library;
3. Go to Euro Truck Simulator 2;
4. Click "Play"; 
5. Choose "Launch with DirectX (64-bit). Make sure you chose 64 bit.
6. Start the game;
7. Choose your profile and press "Drive";
8. Close Euro Truck Simulator 2;
9. Start TruckersMP as admin. TruckersMP will start with DirectX for all time. Except you change it again.

 

Solution 3:

 

1. Right click on Euro Truck Simulator 2 in Steam Launcher;

2. Select "Launch with OpenGL";

3. Let the game run and try going into game;

4. Exit the game and go back to steam, right click on Euro Truck Simulator 2 again but this time select "Launch with DirectX (64-Bit)";

5. Again go into game and then exit;

6. Start TruckersMP up and see if the game stops crashing.

Kind regards,
@FreakyBodyX
TruckersMP Support

 

Maybe it helps you:

 

     - if you are newbie in TruckersMP community, go to Knowledge Base section;

     - if you need support, go to Help section or create a ticket here;

     - if you want to learn more about TruckersMP, Euro Truck Simulator 2 and American Truck Simulator, go to Guides section;

     - if you want to join a virtual trucking company, go to VTC section.

Enjoy!

Link to comment
Share on other sites

  • 0

Hey there, @JAMES JDM!

 

It has been three (3) days since the last reply on this topic, and hence we will be moving it to the "Inactive Topics" section. However, if you still need any further help, feel free to message me or any other Support Team member, and we will open this topic again. If you do not send me or another Support Team member a message within one (1) week, we will move this topic to the Unsolved Topics section.

 

Thank you for your participation!

 

Kind Regards,
MHT_
TruckersMP Trial Support

 

/ Locked and Moved to Inactive Topics.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.