Jump to content

Laggier and laggier


Blompy
 Share

Recommended Posts

Hey guys

With the relatively new lighting change and the addition of some DLC's i bought over the course of the years, it has become really tough trying to play multiplayer. Almost every time a truck comes into view or spawns, my game stutters for a brief second or sometimes even more in crowded areas, making it impossible for me and other drivers to play. I can only imagine how terrified the people behind me are.

 

Do you have any advice on what i could do to improve this situation other than literaly lowering every graphic setting i have and playing as if im back in 2006?

Thank you, happy trucking!

 

EDIT: i have a pretty decent PC, feel free to ask if u need more info about it or the dlcs i own that could cause lag

Link to comment
Share on other sites

The only advice I would think of is not going to Calais, C-D Road and Duisburg anymore, I don't know if you tried that already

                                                               Kind regards,

                                                                    Loexie     

                                                                     Find me on:                       

                                                              Steam / World of Trucks / Twitter

 

                                                                                                                                                    YouTube:

                                                                                                                                   Main channel / Second channel
 

                                                                                                                        

Link to comment
Share on other sites

8 minutes ago, .Lucas said:

The only advice I would think of is not going to Calais, C-D Road and Duisburg anymore, I don't know if you tried that already

that would render the entire multiplayer experience to basicaly an empty world, there are a few crowded cities, sure, but most of the map is barren, not to mention the DLC zones. i went from turkey-bulgaria-romania-hungary and saw a total of 4 people.

I was able to drive on c-d road without any issues pre-lighting update, i guess i'll have to do without the fun part from now on though 😟 

Link to comment
Share on other sites

14 hours ago, P h o e n i x said:

I've noticed a lot of lag recently from players who have beacons, you could try disabling/partially disabling the beacons in the console with g_disable_beacons 1/2 in the console

 

That helps out with my FPS, thanks!❤

 

9 hours ago, sam4soumen said:

I'm not sure but may be lowering the graphics scale may reduce the lag however visually wouldn't advice it either. 

I've already lowered pretty much everything to a medium setting, if not even lower ( like shadows for example)

 

3 hours ago, [S.PLH]Warrior said:

It would also be helpful to show your pc specs, also in Truckersmp settings there are some settings that you can play, do you also use mods ? such as summer mod from grimes ?

I will post my pc specs later today when i get home. I do not use any mods while playing multiplayer, no.

 

I already disabled most unnecessary cosmetic stuff from the tab menu in game (like cabin accesories, flags and what not).

 

However, the "game stutter when other people's trucks spawn" problem still remains.

I was thinking maybe there are still too many things that need to load in.

I'm not sure if this is a TMP feature or a thing from Cabin accesories DLC, but ive noticed some people have their truck badge lit up (bot inside the cabin and in front of their truck), colored headlights (a light blueish color). Is  there a way to disable that? Maybe just disabling the DLC? unless its a TMP feature, which i wouldnt know, i dont ever read the patch notes😁

 

sorry for the long post

Link to comment
Share on other sites

The graphics scales are represented in percent from 0 to 400. One is for reflections and the other sharpens images. At 400 you can read the gauges in your truck clearly, at 1-150 they are blurry and hard to read. Adjusting these has made a difference for me in the past. If there at 400, maybe try 200% instead.

Link to comment
Share on other sites

6 hours ago, [S.PLH]Warrior said:

It would also be helpful to show your pc specs

 

GPU: Radeon RX550/550 Series

CPU:  AMD A8-7650K Radeon R7, 10 Compute Cores 4C+6G, 3.8 GHz

RAM: 8 GB

Win 10 

Motherboard: ASUSTeK COMPUTER INC.  A68HM-PLUS

 

 

Here's a list of my store bought DLCs:

Euro Truck Simulator 2 - Scandinavia

Euro Truck Simulator 2 - Beyond the Baltic Sea

Euro Truck Simulator 2 - Going East

Euro Truck Simulator 2 - Italia

Euro Truck Simulator 2 - Viva la France!

Euro Truck Simulator 2 - Cabin Accessories

Euro Truck Simulator 2 - Heavy Cargo Pack

Euro Truck Simulator 2 - High Power Cargo Pack

Euro Truck Simulator 2 - Road to the Black Sea

Euro Truck Simulator 2 - Special Transport

Euro Truck Simulator 2 - Goodyear tyres pack

Euro Truck Simulator 2 - Metallic Paint jobs

Euro Truck Simulator 2 - Wheel tuning pack

 

And here are my graphic settings:

https://ibb.co/HDCn0tz

 

As you can see, everything is medium - low and scaling is already down to 100% 😕

Let me know if there's anything i can change to get rid of the stutter please, and thank you all for trying to help 

Link to comment
Share on other sites

 

28 minutes ago, dajokr said:

Mirror distance to medium. That ones bad for lag i found. Possibly your ISP or modem/router? Try restarting them if you havent already.

 

again, my problem is a stutter caused by other trucks loading in/coming into view

i do not have fps issues or high MS

 

lowering any more graphic settings will simply increase my fps but not get rid of the actual issue

Link to comment
Share on other sites

9 hours ago, ElenaNaomi said:

 

GPU: Radeon RX550/550 Series

CPU:  AMD A8-7650K Radeon R7, 10 Compute Cores 4C+6G, 3.8 GHz

RAM: 8 GB

Win 10 

Motherboard: ASUSTeK COMPUTER INC.  A68HM-PLUS

 

It looks like the CPU you have is an APU meaning it has its own low power graphics chip on it often called integrated graphics. Have you checked to make sure that ETS2 is running on your dedicated graphics card (your Radeon RX550) and not on integrated graphics? This should help both in frames and in stutters and could possibly help you reach better graphics settings. You check by following the instructions found here: https://www.outletapex.com/how-to-force-a-game-to-use-graphics-card/

 

Link to comment
Share on other sites

Hello there! @ElenaNaomi

 

My name is Petr, and I am member of TruckersMP Community. My hobby is asnwering/helping to others with their issues/questions as soon as I am able to. I will do best for you to asnwer your question 

 

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

Firstly, I wanna ask if you did some graphics update, because it could be cause by that, if the driver is bad set. Or it can be some betaversion of the graphics driver.

 

I must say, its interesting, but i will try to help you as I can 🙂. As second I would ask you what areas of the map are you traveling when it drops? 

 

For me, I would recommend you maybe turn off "Load cabin accessories" and also "Load Flags ^. Maybe it wont help too much but helpful, but maybe yes. 

 

Also, try to check this settings: 

 

In - game 

- Enable Vsync  - is always better to having a Stable FPS Rate around 60 than often a Jumping between 180 till 45 or lower.

- Set Scale to 200% could be less 125% and more less - depends on your HW components

- Disable MLAA

- Disable DOF

- Set all following Quality Settings to hight, it do not have everything on max quallity - it depends on your components in your PC

- Disable Anisotropic Filtering by moving the Slider to the left Side.

 

TruckersMP Launcher -  try unclick some of them as Cabin Accesories in another trucks, Flags, and draw distance reduce to min. 

- Development Logging  

- Smoothing Distance

- Load Cabin Accessoires

- Load Flags

- Aditional Lights

- Draw Distance 

aeF6ehV.png

22v1Cqb.png

 

Also please remember, that FPS will drop dramaticlly if you are close or passing a really busy area, once you have crossed the area you will be fine,

 

As last step you can try to re-install your graphics drivers 🙂  + TruckersMP Launcher (clear instalation or with using F1 in launcher)

Its all, I can help you with 🙂 Hope, some of these solutions will help!

 

 

Have a nice day! 

 

Good luck! 

Kind Regards,

RedWolf_TMP 

 

TruckersMP Forum Contributor / Veteran Driver II 

 

Streamer on: https://www.twitch.tv/redwolf_cz

Languages: 🇬🇧 🇨🇿 I 🇸🇰 I Discord: RedWolf [CZ]#0886

Forum Role: Veteran Driver II  (ETS 2: +4,700 hours)

Forum Rank: Enthusiast (4/13)

 

 

 

lihLABN.pngTbgH1VU.png

 

2117614355_role_VeteranII(1).png.a9bb8eb

 

Link to comment
Share on other sites

Hi everyone, thanks once again for replying and trying to help. I'm finaly home, so I can go through your suggestions. I'm sorry but i don't know how to post images directly here, so i'll just drop a few links.

 

Ok, so, first things first

 

14 hours ago, Farm Shark said:

It looks like the CPU you have is an APU meaning it has its own low power graphics chip on it often called integrated graphics. Have you checked to make sure that ETS2 is running on your dedicated graphics card (your Radeon RX550) and not on integrated graphics? This should help both in frames and in stutters and could possibly help you reach better graphics settings. You check by following the instructions found here: https://www.outletapex.com/how-to-force-a-game-to-use-graphics-card/

 

 

I personaly make sure to do this before I play any game, double checked right now and ETS2 is set to run on the dedicated card.

 

7 hours ago, RedWolf_TMP said:

Firstly, I wanna ask if you did some graphics update, because it could be cause by that, if the driver is bad set. Or it can be some betaversion of the graphics driver.

 

My PC is custom made, bought roughly 3 years ago, no graphic changes have occured ever since and i have been playing ETS2 regularly since then without major issues like this one.

 

7 hours ago, RedWolf_TMP said:

In - game 

- Enable Vsync  - is always better to having a Stable FPS Rate around 60 than often a Jumping between 180 till 45 or lower.

- Set Scale to 200% could be less 125% and more less - depends on your HW components

- Disable MLAA

- Disable DOF

- Set all following Quality Settings to hight, it do not have everything on max quallity - it depends on your components in your PC

- Disable Anisotropic Filtering by moving the Slider to the left Side.

 

Enabling Vsync made the stutters even worse

Scale is already down to 100%

I don't know what MLAA is, sorry

I will leave my graphic settings here again: https://imgbb.com/HDCn0tz

Will disable DOF and come back to you with an edit to see if it made any difference.

 

 

7 hours ago, RedWolf_TMP said:

TruckersMP Launcher -  try unclick some of them as Cabin Accesories in another trucks, Flags, and draw distance reduce to min. 

- Development Logging  

- Smoothing Distance

- Load Cabin Accessoires

- Load Flags

- Aditional Lights

- Draw Distance 

https://ibb.co/xHzxCNS

https://ibb.co/DfbxT67

 

 

7 hours ago, RedWolf_TMP said:

As second I would ask you what areas of the map are you traveling when it drops? 

 

No particular area, the stutters happen whenever 5-6 or more trucks load in at once.

 

My guess is there's no real solution to this other than upgrading my PC. ETS2 may be an old game but it has received quite some modern updates.

Thanks for reading.💘

 

EDIT: Disabling DOF made no difference to the stuttering.

Link to comment
Share on other sites

On 8/23/2021 at 5:59 PM, ElenaNaomi said:

My guess is there's no real solution to this other than upgrading my PC. ETS2 may be an old game but it has received quite some modern updates.

Did it start happening after the 1.40 update?

Because it doesn't really make sense I used to play TMP on a very old PC and I didn't have issues with frame drops except the low frame rate which is normal with an old PC but other than that it was all good, never had issues with stutter and fps drops. So it's either because of the new lighting system which I honestly doubt or something that is rather able to be fixed, because as I mentioned I used to run TMP on a PC that is worse than yours and never had stutters or fps drops.

spacer.png

Phoenix VTC
Driver

https://phoenixvtc.com/

 

Discord: Forceous#6964

 

Link to comment
Share on other sites

  • 2 weeks later...

Heya :),

 

Since your topic has been inactive for over fourteen (14) days, I will lock and move it to our Archive section. 
We apply these procedures, in order to keep the forum organized and structured. 

 

If you have any questions, feel free to DM me. 

 

//Locked & Moved to Archive

 

Kind Regards

Nody,
TruckersMP Forum Moderator.

Link to comment
Share on other sites

  • Nody locked this topic
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.