Jump to content
  • 0

Unsupported game version detected


lamka02sk
 Share

Question

Hey guys, i just downloaded MP for ETS2 and I installed it. But when I try to launch it, it writes error, that the game version is not supported and that I need 1.16.2s version to install. I tried all the betas on Steam but still does not work. Can you tell me please how can I play it?

 

Thank you so much!

 

Greetings lamka02sk

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Actually with the upcoming 1.17 release I already change my 'beta' to temporary_1_16_02.

After changing the 'beta' version, it is usually wise to 'check local cache'.

510 Horses and one lucky bird at work


Simulators: Prepar3d V4, X-Plane 11, DCS 1.5 + 2.x, ETS2, ATS, Farming Simulator 17, Omsi 1 + 2

System: Intel i7-6700K @ 4700Mhz, 32GB DDR4 Corsair Vengeance LPX, GTX970,  HP LP2475w monitor (1920x1200)
Devices: Logitech G27, SKRS Shifter, CH Products Throttle Quadrant, Trustmaster Hotas Joystick, TrackIR
Storage: 2 x SM961 - 250GB (raid 0), Samsung 850 pro 1TB disk, Samsung 850 EVO 2TB disk.

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.