Jump to content

Question

As I've seen in videos, the CB radio in your truck is supposed to be interactive and on when you first join, and you have the option to turn it off or change the dial to switch channels. My radio is blacked out and any keybind/button clicking/voice activation (x) doesn't work. I've tried to re-install both the drivers (Fn + F1 in the launcher) and re-installing the launcher (and deleting the files) and they don't work. Is there any other solution to solve my problem?

Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 1

Hello @shotgunw,

 

If the above doesn't help, please also try the following:

 

Try changing your game to DirectX :) 

You'll need to start up the game with DirectX11 through steam, then drive a short distance in singleplayer.
After that, save and close the game.


Now try joining MP again :)

 

I hope that helps :) 

 

Sincerely,
General18
TruckersMP - Support

  • Like 1

General18

TruckersMP - Support Team

spacer.png

My supported languages: English, Danish

Support | TruckersMP Rules | Feedback | How To Downgrade

Link to post
Share on other sites
  • 1

Hello there.

 

Since you got the answer, I will go ahead and move this topic to solved topics. 

If you have anymore issues in the future, feel free to contact us again. 

 

Kind regards,
TARK777

TruckersMP - Trial Support 

 

//Locked and moved to Solved Topics 

Link to post
Share on other sites
  • 0

Hello @shotgunw  :) 

 

 

First of all, welcome to the TruckersMP forum.

 

Have you tried resetting your sound settings in the game?

 

>The save you are using may be corrupted, you can use a new save file.

>Make sure that the correct device is selected in Steam> Settings> Communication> Audio recording device, and test the microphone from the same place.

>Open the game. Right click the speaker icon from the bottom right of the start bar on the desktop and come to the "Recording Devices" section. Highlight only one.

>Press the "TAB" key in the game and try to adjust your Voice Chat settings from the settings section.

 

Try it and tell us if it worked:

(This was made in a Scania R 2009 truck, in different trucks the CB radio can be located in a different place, but the controls should be in the same places)

 

 Check MP settings (the small cog in the lower left corner of the Players Near You window) and see if in General, you have "Default CB radio channel" in 19 (it can be changed). Maybe that space is blank, never seen it like that, but I can't think of anything else. Other than doing a repair or clean reinstall of the TMP launcher. To try the easiest way, run the launcher and hit F1, so it will download all files again. If that doesn't work, you can also try uninstalling the launcher, then go to C:\Program Data\ and delete the TruckersMP folder. Then download from the website and install again: https://truckersmp.com/download

 

 

I am waiting your return...

 

Kind Regards

Drexy

  • Like 1
Link to post
Share on other sites
  • 0

Hai, @shotgunw

First off, thank you for creating a topic and welcome to the TruckersMP forum! :)

 

There are a few things you may need to check:

1. Check your default microphone - it shouldn't be set to stereo mix or similar
2. Check if your headset has the mic mute switch somewhere. If you find it, set it into the opposite state - you might've muted the mic by accident.
3. Check the volume of the default microphone - if it's very low(close to 0%), raise it up.
4. Check if you have plugged in the microphone into a microphone connector(may not be applicable for USB headsets).
 
Also, make sure that CB radio is actually turned on in-game.
If everything listed is checked and fixed(if applicable) there are settings in-game to change the volume of CB transmit and receive. 
In the settings(cog icon) select the "sound" tab and you'll find voice and mic volume sliders. First one sets the CB to receive volume, the second one sets the CB to transmit volume.
 
Open your panel with the TAB key multiplayer > Voice > Voice volume setting pull to the right.
Open the game. Return to the desktop. At the time sound level in the audio mixer from the speaker icon, right click on TruckersMP.

 

Please look this topic 

Greetings! 👋 

  • Like 1

''Be Happy! 🙂

Link to post
Share on other sites
  • 0
5 hours ago, General18 said:

Hello @shotgunw,

 

If the above doesn't help, please also try the following:

 

Try changing your game to DirectX :) 

You'll need to start up the game with DirectX11 through steam, then drive a short distance in singleplayer.
After that, save and close the game.


Now try joining MP again :)

 

I hope that helps :) 

 

Sincerely,
General18
TruckersMP - Support

This solved my problem! I was always launching ATS in normal mode and I didn't think it had an affect. 

 

Thanks to you all who welcomed me to the forum and helped me out!

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...