Jump to content

1.39 Support Released!


Recommended Posts

  • Replies 89
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Greetings! Earlier this month, update 1.39 for Euro Truck Simulator 2 and American Truck Simulator was released, and since then, our developers have been working hard on porting our multiplayer clien

Greetings!   Today we have received the following hotfixes to fix game client fatal errors, and compatibility with a new version of American Truck Simulator.   Steering wheel ac

Goodbye, the old Calais. I will miss you. And welcome, the new Calais!

Posted Images

@DigitalThere is a major bug with the truck / trailer browser where if you click on them the game crashes to desktop & a black screen, only way to close it is via task manager ( right click & end task ). I believe its an SCS issue, but it does affect MP as i did it last night! Also on ATS the strobes on the low decks dont function which again is an SCS problem...Just a heads up

  • Thanks 1
Link to post
Share on other sites

But when I play on a other profile, than MP is working fine, but when I go than back to 'change profile', than it crashes. And, anyway, I want to play gladly on my own profile, on that profile I have the most money and XP, so on the other profile I'm skeer and low talented. 

 

Can I solve this? 

Thank you everybody for helping me!!!!!!

Link to post
Share on other sites

Hey @rubentransporting
What issue are you exactly facing? 
I would highly recommend either contacting Support or asking for help in the Forum Support section or looking if you could get your issue solved by reading trough solved topics.
-> https://forum.truckersmp.com/index.php?/forum/55-help/
Sharing a screenshot as to what exatly you're having problems with is helpful! 


 

Link to post
Share on other sites
  • Project Coordinator
1 hour ago, rubentransporting said:

But when I play on a other profile, than MP is working fine, but when I go than back to 'change profile', than it crashes. And, anyway, I want to play gladly on my own profile, on that profile I have the most money and XP, so on the other profile I'm skeer and low talented. 

 

Can I solve this? 

Thank you everybody for helping me!!!!!!

This has been a known bug for some time. It is not strictly related to the 1.39 combability update. The solution is to restart your game to change profile, then re-connect to our servers. :) 

Link to post
Share on other sites
  • Project Coordinator
9 minutes ago, Tygrysek520 said:

Uhm...on ETS 2 Map I can see some new countries like Iraq, Egypt etc. but I don't have them in game on signle player and multiplayer aswell. Does anyone have the same?

Hi, I believe it's part of the Middle-East pack for ProMods 2.51: https://www.promods.net/addon.php 

  • Love it! 1
Link to post
Share on other sites
19 hours ago, Digital said:

Thank you for letting us know. We have received multiple reports of steering wheel accessories causing a game fatal error. As a temporary fix, please try to remove these accessories in Single Player, then re-connect to our servers.

 

Please let us know the outcome! In the meantime, our developers will investigate and push a fix as soon as possible.

 

No problem :)

 

Issue was fixed with a TruckersMP update so unable to try your suggestion, thank you anyway!

Link to post
Share on other sites
On 11/24/2020 at 7:45 PM, ScaniaFan89 said:

@DigitalThere is a major bug with the truck / trailer browser where if you click on them the game crashes to desktop & a black screen, only way to close it is via task manager ( right click & end task ). I believe its an SCS issue, but it does affect MP as i did it last night! Also on ATS the strobes on the low decks dont function which again is an SCS problem...Just a heads up

Not crashing in singleplayer for me, even when loading my multiplayer profile.

Strobes works just fine on lowboys in singleplayer, so I don't know where the problem is, not synced in multiplayer?

 

Not sure if it's only multiplayer related, but if you are called for detailed inspection (that one where you are required to stop and turn the engine off) at border checks, the cutscene doesn't seem to end on its own and I have to mash escape key to get out of it, though there's no on-screen prompt to do so.

Link to post
Share on other sites
On 12/3/2020 at 5:20 AM, WI$NIAAa said:

how to set 1.39.2.10 ATS?

ATS is now on 1.39.3.3s, so you would have to go to the Steam Library > Right click on American Truck Simulator > Properties > Betas > NONE - Opt out of all beta programs and then wait for Steam to update it and then try to load the TruckersMP Launcher again. If this does not happen, then please refer to this knowledge base article: https://truckersmp.com/kb/26. I hope this helps answer your question! 

Link to post
Share on other sites
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...