Jump to content

SavageKieran

Veteran Driver III
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Truck?

2 Followers

About SavageKieran

  • Rank
    No Cargo
  • Birthday 03/15/2003

Profile Information

  • Gender
    Male
  • Location
    UK
  • Preferred Trucks
    Peterbilt
    Renault
    Scania
    Volvo
  • American Garage Location
    California: San Francisco
  • EU Garage Location
    Germany: Stuttgart

Recent Profile Visitors

486 profile views
  1. I've just received my second ever ban which is false, and guess what - my first ever ban was also false. Yes, I have appealed, but I can't say I'm impressed with TruckerMP admins.

    1. jukeboxknox

      jukeboxknox

      So you werent at EP with a car?

    2. SavageKieran

      SavageKieran

      I was going into EP with a car and when I drove past the admins, I got banned, I know that cars are not allowed in EP, but I was escorting a friend to London and we went via EP as we were in Rotterdam. I've read the rules and apperantly you're allowed in EP with a car if you're apart of a convoy, to which I was.

    3. jukeboxknox

      jukeboxknox

      If you were apart of a convoy and you have proof then just wait for the mod to look at your appeal.

  2. Wow. I get temp banned for apperantly blocking, when I was turning around.

    1. Show previous comments  2 more
    2. SavageKieran

      SavageKieran

      I have appealed already yet, and sorry if you thought I was complaining. I wasn't intending to complain, I was just a little worked up the fact that my ban is false.

    3. Puncake

      Puncake

      Contact clarkinator then

    4. SavageKieran

      SavageKieran

      Nah, it was an easy misunderstanding I'd say.

  3. SavageKieran

    I really need help..

    ^ Thank you very much!
  4. SavageKieran

    I really need help..

    I've recently downloaded the new version of multiplayer, including ATS multiplayer and after I went onto ATS MP, I fillied in my details as I would usually do on ETS MP, then I chose the server I wanted to play on, and when I clicked 'PLAY' it said I had to register my game and I did so. So I then proceeded to play ATS MP and it still said I had to register my game (and yes, I have already restarted my game), so I then clicked 'Yes' and it brought me back to the same site to register in the first place, so then I decided to check if my account was activated by going onto my profile, and it says my account is activated so therefore I should be able to play ATS MP but it still won't let me join the game if I click 'Play', it will come up that I have to register my game which it shouldn't. I was wondering if I could get some help with this, since I would like to play ATS Mp. Thank you.
  5. SavageKieran

    Menu login unclickable - help please

    Indeed
  6. SavageKieran

    Menu login unclickable - help please

    Yeah, that's what I have to do, thanks! Thank you to you guys as well for concerning.
  7. SavageKieran

    Menu login unclickable - help please

    I've tried clicking on the main menu on Singleplayer as well, and nothing works. And yes, I have tried restarting my laptop, as well as the game around 5 times now. So basically, nothing on Euro Truck is clickable on the main menu.
  8. SavageKieran

    Menu login unclickable - help please

    Hey there, I am SavageKieran in-game, and I am having some problems logging in on the game itself. Basically when I click on the game on my desktop, I get the usual two loading screens which I can skip with ESC, and then it comes up with my login which is correct, and when I attempt to click "Login" nothing happens, it also doesn't let me click anything else within this menu like the forgot password button, the server list, and even the x button which allows me to close the game, though there are many other ways to close the game like for example, alt + f4. But yeah, I cannot get onto the game as it will not me click anything on the login menu. EDIT: I've tried also clicking on the main menu of Singleplayer as well, to which I've found doesn't work either, so basically nothing on Euro Truck is clickable. And yes, I have tried restarting my laptop, as well as my game around 5 times now. Please help me! Thanks
×