Jump to content

shanekid3

Driver
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Truck?

About shanekid3

  • Rank
    No Cargo

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Due to the supported version of 1.38 for TruckersMP now. I went to load up TruckersMP and an Error message saying that unsupported game version detected. The expected version is 1.38.1.11 and I have 1.38.0.46 version. Is there anyway i could change its the expected TruckersMP version. Many Thanks
×
×
  • Create New...