Jump to content

Rysiu145

Driver
  • Content Count

    1
  • Joined

  • Last visited

Everything posted by Rysiu145

  1. hi guys i got problem i installed truckersMP but when im cliking on ETS2 its says something like unsupported game version detected Expected ver. 1.31.2.1s You have ver 1.32.3.3 plz help
×
×
  • Create New...