Jump to content

ethan_l13

Veteran Driver II
  • Content Count

    5
  • Joined

  • Last visited

Community Reputation

0 Truck?

About ethan_l13

  • Rank
    No Cargo
  • Birthday 05/05/2003

Profile Information*

  • Gender
    Male
  • Location
    Ireland
  • Preferred Trucks
    Mercedes
    Scania
    Volvo
  • EU Garage Location
    Italy: Milano
  • Known languages
    English, Irish (and some French)

Recent Profile Visitors

103 profile views
  1. Thanks for the responses, I think it might be my potato PC...
  2. Hi, In Simulation 1, there is a 110km/h speed limit currently in place. However many people seem to go way over it as they overtake me, while I'm going 110km/h. Just wondering if this is meant to happen or are they (somewhat) "speed hacking"? Just curious, that's all. Thanks in advance.
  3. Thanks very much @BaldemarDeutsch [EN\TR] and @Mirrland. All problems have now been resolved. Again, thanks a million. Regards, @ethan_l13
  4. Everytime I play ETS2MP, it works fine - except for the following reasons PLAYER LIST - always loads and lists players. However, mouse doesn't appear, and game carries on as if it wasn't open. SOLVED SLEEP - can NEVER get to sleep. Crashes and shows message (i.e. 23.00 - You are getting some rest) and plays continuous sound. SOLVED FERRY/ CHANNEL TUNNEL - same as above. Click 'Embark' once destination is chosen, but crashes. SOLVED IN-GAME - Pressing 'Y' works, but unable to type. F7+Enter works to exit chat. CHAT SOLVED ANY HELP WHATSOEVER WILL BE MUCH APPRECIATED, EVEN IF IT DOESN'T WORK! Thank you.
×
×
  • Create New...