Jump to content

Unsupported version [Euro Truck Simulator 2]

This announcement is no longer active

Lasse

Hello,

 

We are aware of TruckersMP being incompatible with the latest update of Euro Truck Simulator.

Downgrading is not possible at the moment.

 

We are working on an update to support the latest version as soon as possible.

 

Happy Trucking!



×
×
  • Create New...