Jump to content

Unsupported version [ETS2][ATS]

This announcement is no longer active

Lasse

Hello,

 

We aware of TruckersMP being incompatible with the latest update of Euro Truck Simulator 2 and American Truck Simulator.

Please make sure to downgrade both of your games if you wish to keep playing on our mod: Click here

 

We hope to release an update as soon as possible.

 

Happy Trucking!

Support TruckersMP

If you like our work and want to help support our game servers, website, or domain, please consider becoming a Patron. All amounts received will help us to improve our platform.

Become a Patron

You can check out our Merchandise section with various cool items like phone cases, T-shirts, hoodies, mugs and stickers.

Merchandise

If you prefer a one-time donation, these payment options are available.



×
×
  • Create New...