Jump to content

TruckersMP incompatible with latest game version

This announcement is no longer active

Prime

Hey everyone

 

We are aware of the recent ATS and ETS game updates and that it is not compatible with the mod. In order to play, please downgrade your ATS and ETS game to 1.33.x for incompatible mods. Our devs are working to get the mod updated to the latest version again as soon as possible.

 

A guide on how to downgrade:

 



×