Jump to content

Incompatible ETS2 & ATS Versions

This announcement is no longer active

mth.

SCS has released an update for Euro Truck Simulator 2 and American Truck Simulator

 

We do not support this update yet on TruckersMP, but fortunately it is possible to downgrade to temporary_1_50 - 1.50.x for incompatible mods!  

 

For information on downgrading your game, please click here.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.