Jump to content

ProMods 2.45 incompatibility

This announcement is no longer active

Μatt

TruckersMP does not support the latest ProMods version 2.45 on our servers. At this moment in time, you can only use ProMods version 2.43 as this is the only version we support. Our developers are working on a patch for the newest version.

×
×
  • Create New...